This is a migrated thread and some comments may be shown as answers.

Installer fails for v2015.10.1221.4

3 Answers 12 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Richard
Top achievements
Rank 1
Richard asked on 26 Jan 2016, 10:30 AM

I'm attempting to update JD in line with the "breaking changes" issue but the linked version as per the title does not install.

The splash screen hangs and eventually shows a message stating there is a "Connection Problem" and asking for proxy details (see attachment).

The URL it is trying to reach is identified in the message box as "https://dl.telerik.com/runtime/v1/info/JD"
I assume this service provides a list of download locations for the installer to get files.
If I load this URL into my browser I get a 500 error.  This has been happening for many months (I've had a few tries at this periodically).

I'm a little surprised nobody has noticed that this service is failing - seems like it's pretty critical to the installation process?

 

Does anyone have any ideas here? I've been unable to locate the URL of an "offline installation package" anywhere on the site.

3 Answers, 1 is accepted

Sort by
0
Ventsi
Telerik team
answered on 28 Jan 2016, 03:53 PM
Hi Richard,

Thank you for reaching us.

I have checked this on our side and the service is working as expected. In addition, this is a secured service and it is not designed to work and return information when loaded in your web browser.

In regard to the connection issue of the web installer, could you please double check that nothing (a policy, firewall, antivirus software etc.) blocks the calls to our services? You can also discuss this with your system administrator.

Meanwhile, could you please log into your Telerik account and try to download the offline installation package from our Trial Files for Offline Installation page?

We are looking forward to hearing from you.

Regards,
Ventsi
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
0
Richard
Top achievements
Rank 1
answered on 10 Feb 2016, 04:18 AM

There is no connection policy that could be at play here.  I have complete, unfettered access to the internet.  I am the system administrator.

I tried to intercept the traffic with Fiddler but that also doesn't work (this time it's the oauth token exchange) I expect the SSL interception is the issue there.

 

 

0
Ventsi
Telerik team
answered on 12 Feb 2016, 02:10 PM
Hi Richard,

The service is running and works as expected.

Did you check if your firewall or antivirus software blocks the installer or the requests it makes? Another thing you can do is to try the installer:
  • on another machine connected to your network
  • on your machine but connected to another network

This way we can exclude the configuration of your system as possible cause for this issue.

In addition, did you manage to download the offline installer of the product and install it?

We really appreciate your patience and cooperation.

Regards,
Ventsi
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Tags
General Discussions
Asked by
Richard
Top achievements
Rank 1
Answers by
Ventsi
Telerik team
Richard
Top achievements
Rank 1
Share this question
or