Install failed System.IO.FileNotFoundException WIN 10

6 posts, 0 answers
  1. core
    core avatar
    1 posts
    Member since:
    Jan 2018

    Posted 11 Jan Link to this post

    ---------------------------
    Initialization of CONFIG Prefs Failed
    ---------------------------
    Fiddler has encountered an unexpected problem. If you believe this is a bug in Fiddler, please copy this message by hitting CTRL+C, and submit a bug report at http://www.telerik.com/forums/fiddler.

    Could not load file or assembly 'System.Core, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system cannot find the file specified.

    Type: System.IO.FileNotFoundException
    Source: Fiddler
       at Fiddler.PreferenceBag..ctor(String sRegPath)

       at Fiddler.CONFIG.() in C:\JenkinsHome\jobs\FiddlerReleaseBuild\workspace\Fiddler2\Common\Application\Config.cs:line 1956

       at Fiddler.CONFIG..cctor() in C:\JenkinsHome\jobs\FiddlerReleaseBuild\workspace\Fiddler2\Common\Application\Config.cs:line 1935


    Fiddler v5.0.20173.50948 (x64 AMD64) [.NET 4.0.30319.42000 on Microsoft Windows NT 10.0.14393.0] 
    ---------------------------
    OK   
    ---------------------------

  2. Alexander
    Admin
    Alexander avatar
    336 posts

    Posted 18 Jan Link to this post

    Hello,

    This is very weird error. System.Core is part of the .NET Framework and such exceptions may indicate corrupted installation of the framework. You can try repairing/reinstalling the .NET Framework using the appropriate installer from Microsoft's website.

    Regards,
    Alexander
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Med
    Med avatar
    2 posts
    Member since:
    May 2018

    Posted 30 May Link to this post

    Hi there. I have almost the same problem. Screenshot is attached.

    Win 7 SP1.

    Appreciate any help.

    Thank you

  4. Alexander
    Admin
    Alexander avatar
    336 posts

    Posted 31 May Link to this post

    Hi,

    It seems that Fiddler's installation is corrupted. Would you mind trying reinstallation of Fiddler?

    Regards,
    Alexander
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  5. Med
    Med avatar
    2 posts
    Member since:
    May 2018

    Posted 31 May Link to this post

    Thanks for you reply, Alexander.

    I have found the problem. It was CIS (Comodo Internet Security) not giving the app full permissions as it was supposed to. I have now made sure Fiddler.exe has all the permissions it needs in CIS and everything appears to be working as it should.

     

    Sorry for the waste of your time. Perhaps this may help someone in the future.

     

    Regards

    Med

  6. Alexander
    Admin
    Alexander avatar
    336 posts

    Posted 01 Jun Link to this post

    Hello,

    Glad you worked it out. And yes, it could help someone in the future, so thank you for sharing the solution.

    Regards,
    Alexander
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top