This is a migrated thread and some comments may be shown as answers.

HTTPS decryption stopped working

9 Answers 559 Views
Fiddler Classic
This is a migrated thread and some comments may be shown as answers.
Michael
Top achievements
Rank 1
Michael asked on 17 May 2015, 06:06 AM

Hey guys,

Bit stumped on this one - Just today HTTPS decryption has stopped working properly.

 To Be precise, if it is enabled, no data appears to be proxied to/from Fiddler. In Chrome/IE/Firefox, the session just hangs waiting for a response which never comes.

If I disable HTTPS decryption, everything works as expected.

I have double checked the certificate and reinstalled it (though if it were a problem I would expect the browser to tell me anyway!), I have reinstalled Fiddler and tried using a different PC (across the network, still via my local copy of Fiddler).

Has anyone seen this? I'm not sure where I should go from here!

 Cheers,

Michael

9 Answers, 1 is accepted

Sort by
0
Eric Lawrence
Telerik team
answered on 19 May 2015, 11:10 AM
Hi, Michael--

1. What, if anything, do you see on Fiddler's LOG tab?
2. Do you see the normal "Tunnel to" entries in Fiddler's Web Sessions list?
3. Which certificate generator are you using? Tools > Fiddler Options > HTTPS will say on the right-hand side under "certificates generated using"

Regards,
Eric Lawrence
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
0
Francesco
Top achievements
Rank 1
answered on 04 Jun 2015, 05:03 PM
Hello Eric I have problem with fiddler from 1 month, for many years work well and now don't work, when i open fiddler traffic is found but with red triangles, and the page of the game which I open, locks
0
Eric Lawrence
Telerik team
answered on 04 Jun 2015, 05:29 PM
Hi, Francesco--

To get help, you'll need to answer the same questions I asked earlier:

1. What, if anything, do you see on Fiddler's LOG tab?
2. Do you see the normal "Tunnel to" entries in Fiddler's Web Sessions list?
3. Which certificate generator are you using? Tools > Fiddler Options > HTTPS will say on the right-hand side under "certificates generated using"


Regards,
Eric Lawrence
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
0
Francesco
Top achievements
Rank 1
answered on 05 Jun 2015, 06:18 PM
 [Fiddler] No HTTPS request was received from (chrome:696) new client socket, port 2367.this maybe is the problem? white lock on the left captures traffic, descript traffic is enable also autoresponder and unmatched is enable. Thank you for help me tanks so much
0
Eric Lawrence
Telerik team
answered on 05 Jun 2015, 06:25 PM
The message "No HTTPS request was received" indicates that the client established a HTTPS connection but subsequently failed to send a request on that connection. That could happen, for instance, if the client was not configured to trust Fiddler's Root Certificate.

Answers to my other questions might help further. You might also say what you see with other browsers (e.g. Internet Explorer).

Sending me a SAZ file (File > Save All Sessions, then attach to an email created by clicking Help > Send Feedback) showing the "Red triangles" would also be useful.

Regards,
Eric Lawrence
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
0
Francesco
Top achievements
Rank 1
answered on 05 Jun 2015, 06:41 PM
Thank you for reply Eric , Then my problem is, not configured to trust Fiddler's Root Certificate? how can I fix it?
1
Eric Lawrence
Telerik team
answered on 05 Jun 2015, 08:48 PM
You can get prompted to trust Fiddler's root certificate again as follows:

 1. Click Tools > Fiddler Options HTTPS.
 2. Untick "Decrypt HTTPS traffic"
 3. Click "Remove Interception Certificates"
 4. Accept all prompts.
 5. Tick "Decrypt HTTPS traffic" again
 6. Accept all prompts.

Answers to my other questions might help further. You might also say what you see with other browsers (e.g. Internet Explorer).

Sending me a SAZ file (File > Save All Sessions, then attach to an email created by clicking Help > Send Feedback) showing the "Red triangles" would also be useful.


Regards,
Eric Lawrence
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Milo
Top achievements
Rank 2
commented on 19 Aug 2022, 09:55 AM

Thank you Eric! :D
"Remove Interception Certificates" solved my problem. :)
0
Francesco
Top achievements
Rank 1
answered on 05 Jun 2015, 10:01 PM
I follow all you step , no way , same for mozilla or internet explorer, same problem 
0
Eric Lawrence
Telerik team
answered on 08 Jun 2015, 06:13 PM

I can't help you without answers to my questions.

Please consider this thread closed; if you would like help, please use the Help > Send Feedback menu to send answers to the questions below directly to our product support team.

Thanks!

Eric Lawrence
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Tags
Fiddler Classic
Asked by
Michael
Top achievements
Rank 1
Answers by
Eric Lawrence
Telerik team
Francesco
Top achievements
Rank 1
Share this question
or