HTTPS Certificate failure on Windows 10 Client

2 posts, 0 answers
  1. Dan
    Dan avatar
    1 posts
    Member since:
    Aug 2017

    Posted 11 Aug 2017 Link to this post

    I am on windows 10 with a Java 8 Application talking to a remote server.  When I enable decode HTTPS and I go ahead and generate and install and say trust the root certificate.  When I run my application with Fiddler I get the following:

     

    16:10:54:9362 /Fiddler.CertMaker> Invoking CertEnroll for Subject: CN=*.v1host.com, O=DO_NOT_TRUST, OU=Created by http://www.fiddler2.com; Thread's ApartmentState: MTA
    16:10:54:9372 /Fiddler.CertMaker> Reusing PrivateKey for '*.v1host.com'
    16:10:55:0284 /Fiddler.CertMaker> Finished CertEnroll for 'CN=*.v1host.com, O=DO_NOT_TRUST, OU=Created by http://www.fiddler2.com'. Returning cert
    16:10:55:2048 !SecureClientPipeDirect failed: System.Security.Authentication.AuthenticationException A call to SSPI failed, see inner exception. < An unknown error occurred while processing the certificate for pipe (CN=*.v1host.com, O=DO_NOT_TRUST, OU=Created by http://www.fiddler2.com).

    The program works fine when I dont have fiddler running.

    What am I missing

  2. Alexander
    Admin
    Alexander avatar
    336 posts

    Posted 17 Aug 2017 Link to this post

    Hello,

    AFAIK Java applications does not use the Windows certificate store (which Fiddler is adding the root certificate to) and use separate Java store. Have you tried adding the Fiddler root certificate in the Java certificate store?

    First you need to export the Fiddler root certificate (Options -> HTTPS -> Actions -> Export root certificate to Desktop). Then you must add it to the Java CA certificate store (this article seems to be explaining exactly that).

    Regards,
    Alexander
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top