HTTP request via composer keeps taking me to signin page

2 posts, 0 answers
  1. Peter
    Peter avatar
    1 posts
    Member since:
    Jul 2016

    Posted 18 Jul 2016 Link to this post

    Hi, I am trying to do a simple GET request via the composer for URL like https://<xxx>

    And it keeps going to https://<xxx> instead of returning the data.  I can paste the link in the browser and gets the results in a json file just fine.

    I have automatically authenticate enabled under options, and I have tried including "Authorization: Basic <my personal access token>" in the header as well, but neither worked.

    Does anyone know a way to work around this?  Thanks.


  2. Tsviatko Yovtchev
    Tsviatko Yovtchev avatar
    549 posts

    Posted 26 Jul 2016 Link to this post


    Automatically authenticate will try authenticating with the credentials of your machine/domain user. Are you sure these will work for the domain mentioned?

    You might be logged in with the browser and the browser might use the session cookie for authentication. Why don't you compare the browser request with what you are composing?

    Tsviatko Yovtchev
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top