How Can I filter out (hide) a Chrome extension

19 posts, 0 answers
  1. Frederik
    Frederik avatar
    2 posts
    Member since:
    Jun 2018

    Posted 05 Jun 2018 Link to this post

    Hello,

    I am new with Fiddler.  Please bear with my inexperience. :-)

    My result panel is polluted with a Chrome extension 500 error. The URL is http://127.0.0.1:55296/ChromeExt/pabeoippfoppjkpbmbpjjjglbldlajfg.  Please find a screenshot attached.

     

    Could you please tell me what my filter options would be?

    I have tried:

    * Filter rule: Request header > Hide if URL contains: "/ChromeExt/pabeoippfoppjkpbmbpjjjglbldlajfg"

    * Script rule:

    if ( oSession.url.Contains("/ChromeExt/pabeoippfoppjkpbmbpjjjglbldlajfg") ) 
            {   
                oSession["ui-hide"] = "yup"; // "The "yup" value is unimportant"
            }

     

    What am I missing?

     

    Thanks in advance for your help

     

     

  2. Frederik
    Frederik avatar
    2 posts
    Member since:
    Jun 2018

    Posted 06 Jun 2018 in reply to joker Link to this post

    hahaha This is a good one.  Was not sure if you were serious until I saw you username.

    Have a nice day

  3. Alexander
    Admin
    Alexander avatar
    383 posts

    Posted 12 Jun 2018 Link to this post

    Hi Frederik,

    Please, pardon us for the delay in our answer.

    Is the value in the "Hide if URL contains" filter rule with the quotes or without them? In which method did you put the script rule?

    Regards,
    Alexander
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  4. Humuro
    Humuro avatar
    1 posts
    Member since:
    Jul 2018

    Posted 30 Jul 2018 Link to this post

    This post is indeed good, so far so good. 
  5. Frank
    Frank avatar
    4 posts
    Member since:
    Aug 2018

    Posted 02 Aug 2018 Link to this post

    I'm having same issue.  I used essentially the same code in the OnBeforeResponse method.  I can't seem to get rid of '/ChromeExt/pabeoippfoppjkpbmbpjjjglbldlajfg'.

    If i right click on the result panel and click 'filter now' and '/chromeext/' ... it filters from the result panel and then new ones start coming in.

     

  6. Alexander
    Admin
    Alexander avatar
    383 posts

    Posted 07 Aug 2018 Link to this post

    Hi Frank,

    Would it be possible that you share the name of the extension? I would like to try to reproduce the problem you have.

    Regards,
    Alexander
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  7. Frank
    Frank avatar
    4 posts
    Member since:
    Aug 2018

    Posted 07 Aug 2018 in reply to Alexander Link to this post

    After additional research, it appears to be an extension that is not from the web store but from employer. 

    You can close my inquiry.  Thank you for your time.

     

  8. James
    James avatar
    1 posts
    Member since:
    Sep 2018

    Posted 06 Sep 2018 Link to this post

    There's a way of filtering out all these requests. In the network tab filter box, use the string "-Scheme:chrome-extension" (quotes for clarity). It would be a good thing to be able to activate this filter (or other filters) by default (as part of the configuration settings). Note that this filter will not filter the http/https requests made by an extension, if any. The real solution is for the network waterfall to have separated channels for the page and each of the extensions.
  9. Frank
    Frank avatar
    4 posts
    Member since:
    Aug 2018

    Posted 06 Sep 2018 in reply to James Link to this post

    I can't seem to locate the network tab in Fiddler.  

    I've already tried the filter tab and added 'Hide if URL contains' /ChromeExt and that did not work.  I've also attempted to filter thru script rules.  Both of these options are discussed in the original post from Frederik.
  10. Tom
    Tom avatar
    4 posts
    Member since:
    Aug 2018

    Posted 22 Sep 2018 Link to this post

    You can locate the extension settings by navigating to Web Filter > Mobile Devices > Web Filter Extension for Google Chrome.

    See this result: http://files.lightspeedsystems.com.s3.amazonaws.com/CS%20Videos/WF%20-%20ChromeMF2.gif

  11. Tom
    Tom avatar
    4 posts
    Member since:
    Aug 2018

    Posted 22 Sep 2018 in reply to Tom Link to this post

    Tom said:

    You can locate the extension settings by navigating to Web Filter > Mobile Devices > Web Filter Extension for Google Chrome.

    See this result: http://files.lightspeedsystems.com.s3.amazonaws.com/CS%20Videos/WF%20-%20ChromeMF2.gifpc

    The Web Filter Extension for Google Chrome works with your Rocket to provide off-network filtering for Chromebooks. The extension for Chrome provides content filtering for ChromeOS, allowing school administrators to ensure safe, monitored access on school-distributed Chromebooks. Operating as a Chrome extension, it offers policy-based filtering and off-network activity reporting–all without the need for a proxy. In addition, it provides seamless single sign-on capabilities for ChromeOS devices when they are used off the school network.
    The Web Filter Extension for Google Chrome is the safest iteration of our Google Chrome extension to date! The new Extension for Google Chrome is created uniquely for your organization. Only you and you alone have access to this extension, ensuring a seamless deployment and filtering experience.

  12. Michelle
    Michelle avatar
    2 posts
    Member since:
    Sep 2018

    Posted 23 Sep 2018 in reply to Frederik Link to this post

    Frederik said:

    Hello,

    I am new with Fiddler.  Please bear with my inexperience. :-)

    My result panel is polluted mybkexperience with a Chrome extension 500 error. The URL is http://127.0.0.1:55296/ChromeExt/pabeoippfoppjkpbmbpjjjglbldlajfg.  Please find a screenshot attached.

    Could you please tell me what my filter options would be?

    I have tried:

    * Filter rule: Request header > Hide if URL contains: "/ChromeExt/pabeoippfoppjkpbmbpjjjglbldlajfg"

    * Script rule:

    if ( oSession.url.Contains("/ChromeExt/pabeoippfoppjkpbmbpjjjglbldlajfg") ) 
            {   
                oSession["ui-hide"] = "yup"; // "The "yup" value is unimportant"
            }

    What am I missing?

    Thanks in advance for your help

    How did you solve it?

  13. David
    David avatar
    1 posts
    Member since:
    Oct 2018

    Posted 18 Oct 2018 in reply to BALA Link to this post

    BALA said:

    I'm also having the same problem most of the people are having the same issue it's really annoying Please help us.

    Best Regards,
    Bala Krishna

     

    Still, everyone faces this issue? No one can find the solution or what actual problem?

  14. Prasad
    Prasad avatar
    2 posts
    Member since:
    Oct 2018

    Posted 18 Oct 2018 Link to this post

    Not quite the solution I was after (I'd have preferred a global setting), but there is now a way to filter out requests from extensions.

    Step: In the network tab filter box, enter the string -scheme:chrome-extension (as shown below):. 

    This is case-sensitive, so make sure it's lowercase. Doing this will hide all resources which were requested by extensions.

    --------------------------------

    http://appvn.io/

  15. Marten
    Marten avatar
    1 posts
    Member since:
    Oct 2018

    Posted 26 Oct 2018 in reply to Prasad Link to this post

    Prasad said:

    Not quite the solution I was after (I'd have preferred a global setting), but there is now a way to filter out requests from extensions.

    Step: In the network tab filter box, enter the string -scheme:chrome-extension (as shown below):. 

    This is case-sensitive, so make sure it's lowercase. Doing this will hide all resources which were requested by extensions.

    --------------------------------

    http://appvn.io/

    Thank you and regards, showbox apk

  16. David
    David avatar
    2 posts
    Member since:
    Nov 2013

    Posted 29 Oct 2018 in reply to David Link to this post

    Think I figure it out.  Nothing I tried, script-wise, would filter or change them - not even changing the "ui-color".  So I started looking at the log window and found it showing:

     

    14:47:55:1667 Fiddler.Network.ProtocolViolation - [#184] The Server did not return properly formatted HTTP Headers. HTTP headers should be terminated with CRLFCRLF. These were terminated with LFLF.

     

    for these sessions. So I found that by going to "Tools>Options>General" and setting protocol violations to "Do nothing", the "/ChromeExt/" warnings stopped showing up in the session pane and it is much cleaner.

    So, these are warnings and not sessions showing in the pane.

    Hope this helps - cheers!

  17. David
    David avatar
    2 posts
    Member since:
    Nov 2013

    Posted 30 Oct 2018 Link to this post

    Don't know that my post yesterday made it - is this what you're looking for Frederick?

    Think I figure it out.  Nothing I tried, script-wise, would filter or change them - not even changing the "ui-color".  So I started looking at the log window and found it showing:

    14:47:55:1667 Fiddler.Network.ProtocolViolation - [#184] The Server did not return properly formatted HTTP Headers. HTTP headers should be terminated with CRLFCRLF. These were terminated with LFLF.

    for these sessions. So I found that by going to "Tools>Options>General" and setting protocol violations to "Do nothing", the "/ChromeExt/" warnings stopped showing up in the session pane and it is much cleaner.
    So, these are warnings and not sessions showing in the pane.
    Hope this helps - cheers

  18. Frank
    Frank avatar
    4 posts
    Member since:
    Aug 2018

    Posted 30 Oct 2018 in reply to David Link to this post

    This worked. Thank you. Those warnings were really annoying. 

  19. John
    John avatar
    1 posts
    Member since:
    Mar 2019

    Posted 13 Mar in reply to David Link to this post

    David said:

    Don't know that my post yesterday made it - is this what you're looking for Frederick?

    Think I figure it out.  Nothing I tried, script-wise, would filter or change them - not even changing the "ui-color".  So I started looking at the log window and found it showing:

    14:47:55:1667 Fiddler.Network.ProtocolViolation - [#184] The Server did not return properly formatted HTTP Headers. HTTP headers should be terminated with CRLFCRLF. These were terminated with LFLF.

    for these sessions. So I found that by going to "Tools>Options>General" and setting protocol violations to "Do nothing", the "/ChromeExt/" warnings stopped showing up in the session pane and it is much cleaner.
    So, these are warnings and not sessions showing in the pane.
    Hope this helps - cheers

    live net tv

     

    Thank you for the updates this thread.

    It's really helped. :)

Back to Top