getting "authentication required"

3 posts, 0 answers
  1. g
    g avatar
    2 posts
    Member since:
    Jul 2018

    Posted 14 Jul Link to this post

    Hi, 

     

    I used fiddler composer to send a request from windows machine, but I receive 407, I turned on "auto authenticate" in options. So there is what I see in the sessions window:

    session1:

    GET http://www.example.com/ HTTP/1.1
    User-Agent: Fiddler
    Host: www.example.com


    HTTP/1.1 407 authenticationrequired
    Date: Sat, 14 Jul 2018 07:44:18 GMT
    Content-Type: text/html
    Cache-Control: no-cache
    Content-Length: 12629
    Proxy-Connection: Keep-Alive
    Proxy-Authenticate: Negotiate
    Proxy-Authenticate: NTLM


    session2:

    GET http://www.example.com/ HTTP/1.1
    User-Agent: Fiddler
    Host: www.example.com
    Proxy-Authorization: Negotiate TlRMTVNTUAABAAAAl4II4gAAAAAAAAAAAAAAAAAAAAAGAbEdAAAADw==


    HTTP/1.1 407 authenticationrequired
    Date: Sat, 14 Jul 2018 07:44:18 GMT
    Content-Type: text/html
    Cache-Control: no-cache
    Content-Length: 12629
    Proxy-Connection: Keep-Alive
    Proxy-Authenticate: NTLM
    Proxy-Support: Session-Based-Authentication

    --------------------------------------------

     

    And that's it. How do I make it to go through?

     

    Thanks in advance.

  2. g
    g avatar
    2 posts
    Member since:
    Jul 2018

    Posted 14 Jul in reply to g Link to this post

    Also , here is what I see in the LOG panel:

     

    09:44:18:5157 Automatic authentication of Session #12 was unsuccessful. System.Exception AuthenticationManager.Authenticate returned null.
       at Fiddler.Session.ž() in C:\JenkinsHome\jobs\FiddlerReleaseBuild\workspace\Fiddler2\Common\Core\Session.cs:line 4427

  3. Kammen
    Admin
    Kammen avatar
    329 posts

    Posted 20 Jul Link to this post

    Hi,

    When you enable auto authenticate, Fiddler is using the default credentials to authenticate. You can specify username and password to authenticate with as follows:

    static function OnBeforeRequest(oSession: Session)    
    {      
       if (oSession.HostnameIs("ServerUsingChannelBinding"))
       {        
            oSession["x-AutoAuth"] = "username:MyP@$$w0rd";     
       }
    }

    Hope this helps.

    Regards,
    Kammen
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top