File Not Found exception when using Chrome

3 posts, 0 answers
  1. Stuart
    Stuart avatar
    2 posts
    Member since:
    Apr 2013

    Posted 13 Jul 2014 Link to this post

    Hi, I am trying to fire NUnit tests under TeamCity and my tests falls a the first hurdle.

    When I execute the following:

    _manager.LaunchNewBrowser(BrowserType.Chrome, true);

    I get:

    SportsArb.Test.dll] 853 ERROR SportsArb.Execution.Agents.UICommon.WebManager - Error setting up browser: System.ComponentModel.Win32Exception (0x80004005): The system cannot find the file specified
    at System.Diagnostics.Process.StartWithShellExecuteEx(ProcessStartInfo startInfo)
    at System.Diagnostics.Process.Start()
    at System.Diagnostics.Process.Start(ProcessStartInfo startInfo)
    at ArtOfTest.WebAii.Messaging.Process.HostsProxy.Start()
    at ArtOfTest.WebAii.Messaging.Process.HostsProxy.RegisterListener(MessageListener listener)
    at ArtOfTest.WebAii.Messaging.Process.ExecutionMediator.RegisterManager(Manager manager)
    at ArtOfTest.WebAii.BrowserSpecialized.Chrome.ChromeActions.LaunchNewBrowserInstance(Manager manager)
    at ArtOfTest.WebAii.Core.Manager.LaunchNewBrowser(BrowserType browserToLaunch, Boolean waitForBrowserToConnect, ProcessWindowStyle windowStyle, String arguments)

    Chrome is installed and extensions are in place and enabled.

    I have tried restarting TeamCity with my credentials (has admin) and local service.  I have tried adding a console initiated TC agent, same fault.

    I tried adding the exploratory testing extension to chrome and it installs but it fails to launch with "Cannot launch Telerik Exploratory Tool"

    Any clues what I am doing wrong?

    My test file is C# created using VisualStudio 2010, TeamCity instance is 8.1.3 (build 30101), running on 32 bit Win2008 SP2

  2. Stuart
    Stuart avatar
    2 posts
    Member since:
    Apr 2013

    Posted 13 Jul 2014 in reply to Stuart Link to this post

    Well some DotPeek wrangling later I managed to find out what the issue is.

    The path pointed to by HKLM\SOFTWARE\Telerik\TestStudio\BinPath was not valid so the Manager object wasn't able to launch its proxy executable.

    I simply adjusted this path to point to my Telerik bin path and it now works.

    Worth noting that this was wrong even AFTER a fresh install of Telerik WebAii so I suspect the installer needs to change this value even if previously set.
  3. Cody
    Cody avatar
    3354 posts

    Posted 16 Jul 2014 Link to this post

    Hello Stuart,

    The Telerik Testing Framework does not set the key:

    It is set by the Test Studio installer. Which product did you install? Do you remember what it was set to before you changed it? Also what sort of test were you running? Can we get a copy of it so we can reproduce the problem?

    Quickly become an expert in Test Studio, check out our new training sessions!
    Test Studio Trainings
Back to Top