Fiddler won't start saying there's a machine-wide installation

7 posts, 1 answers
  1. Sameera
    Sameera avatar
    5 posts
    Member since:
    Jul 2012

    Posted 24 Aug 2017 Link to this post

    I've been using Fiddler for a long time (from v1 days) and have had many versions installed. Today, there was an update and during update it stopped saying that it couldn't uninstall the existing version from C:\Program Files (x86)\Fiddler2 and aborted. So, I tried to manually uninstall from Windows 10 Add/Remove as well as by going to the mentioned folder. Fiddler is not present in either (there's no Fiddler2 folder at in Program files folder).

    So, I tried the following:

    1. Downloaded and installed Fiddler to C:\Program files...

    2. Installing to default App Data path

    3. Deleting all references to Fiddler from registry and installing

    Regardless of what I do, the error when running Fiddler is the same:
    ---------------------------
    Machine-wide installation has been found. Progress Telerik Fiddler is closing now.
    ---------------------------
    Machine-wide Progress Telerik Fiddler installation has been found at C:\Program Files (x86)\Fiddler2\ . Please, use that one or uninstall it before starting the per user Fiddler installation.

     

    How do I get around this?

  2. Urbain
    Urbain avatar
    1 posts
    Member since:
    Aug 2017

    Posted 28 Aug 2017 in reply to Sameera Link to this post

    hello

    i got the same problem.

    i don't have the solution to install fiddler 4 but you can uninstall fiddler 4 and go back to fiddler 2

     

    and it's work

  3. Bart
    Bart avatar
    1 posts
    Member since:
    May 2012

    Posted 31 Aug 2017 Link to this post

    Hi I am encountering the same problem. Tried to uninstall  and install again, but problem keeps appearing. Is there any workaround / solution for this?
  4. Answer
    Simeon
    Admin
    Simeon avatar
    195 posts

    Posted 04 Sep 2017 Link to this post

    Hello,

    Sorry about the late reply. In order to reproduce the problem, I need to know from which version of Fiddler you were trying to update to the current one.

    I also need to know which Windows version you use. Could you, please, also tell me if your account has administrative privileges. I am also interested to know if the installer requested for administrative credentials and if you provided some.

    You could try to fix the problem by removing the "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Fiddler2" registry key with all of its subkeys. Please, note that this key is in the "HKEY_LOCAL_MACHINE" root key. If the following registry key is present, delete it as well: "HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Fiddler2"

    Please, let me know if this solves the problem.
     
    Regards,

    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  5. Sameera
    Sameera avatar
    5 posts
    Member since:
    Jul 2012

    Posted 06 Sep 2017 in reply to Simeon Link to this post

    Thanks. Removing the Registry Key worked.
  6. James
    James avatar
    1 posts
    Member since:
    Sep 2017

    Posted 27 Sep 2017 Link to this post

    I know this is an old post but for the sake of future readers. The solution suggested by Simeon, to remove the registry keys, resolved the error for me as well.
  7. Kadir
    Kadir avatar
    1 posts
    Member since:
    Apr 2018

    Posted 23 Apr 2018 Link to this post

    kadir
Back to Top