This is a migrated thread and some comments may be shown as answers.

EWSEditor: Exchange online oauth authentication errors

3 Answers 158 Views
Windows
This is a migrated thread and some comments may be shown as answers.
matt
Top achievements
Rank 1
matt asked on 10 Apr 2020, 03:46 PM

I'm using the latest Fiddler version and O365 extension, but I'm still unable to get through the authentication process when using Oauth.  I've been trying with EWS editor, and both Oauth and basic fail.  Outlook fails to connect to an Exchange Online mailbox.  Using Chrome and IE can't get to outlook on the web, or google.com for that matter.  It seems to be having a problem with SSL, but I'm not clear on that.

 

EWS editor error using basic

Microsoft.Exchange.WebServices.Data.SimpleServiceRequestBase.InternalExecute()

Exception details: Message: The request failed. The underlying connection was closed: An unexpected error occurred on a send.
Type: Microsoft.Exchange.WebServices.Data.ServiceRequestException
Source: Microsoft.Exchange.WebServices

 

EWS editor error using Oauth

System.Threading.Tasks.Task`1.get_Result()

Exception details:
Message: One or more errors occurred.
Type: System.AggregateException
Source: mscorlib

3 Answers, 1 is accepted

Sort by
0
Eric R | Senior Technical Support Engineer
Telerik team
answered on 10 Apr 2020, 05:06 PM

Hi Matt,

It appears that the Office 365 Extension was updated and may no longer supports the EWS Editor. For more information, see the latest release notes on their GitHub Repository.

Once the extension is updated, enabling HTTPS Decryption will be required in Fiddler to view session information. This is also noted on their Wiki.

For any additional issues related to the Office 365 extension, I recommend creating them in their Issues Repository for better results. Technically, we are unable to support third-party extensions.

Please let me know if you need any additional information related to Fiddler. Thank you for using the Forums.

Regards,


Eric R | Senior Technical Support Engineer
Progress Telerik

Progress is here for your business, like always. Read more about the measures we are taking to ensure business continuity and help fight the COVID-19 pandemic.
Our thoughts here at Progress are with those affected by the outbreak.
0
matt
Top achievements
Rank 1
answered on 10 Apr 2020, 05:39 PM
Hi Eric, Thank you for replying.  I'm thinking it may have to do with a local PC trend firewall.  I'm trying to have that disabled, and see where I get.  The problems were encountered with EWS editor, outlook, and browser connections to OOW, and other O365 portals, and also to Google.  And I always have https decryption enabled. 
0
matt
Top achievements
Rank 1
answered on 13 Apr 2020, 06:54 PM
Well, I got it working, but I can't pinpoint the exact cause, or setting. It seems like resetting the certs and cert settings is what ultimately fixed it.
I upgraded EWSeditor to the latest.  It was only one version back. Didn't help.
I changed the OS SSL\TLS client versions enabled(HKLM:\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols). Didn't help.
I changed the supported SSL\TLS versions supported in Fiddler. Didn't help.
I unchecked "ignore server certificate errors" on the HTTPs tab. Didn't help.
I removed the Fiddler certs, and retrusted them. HTTPs tab > Actions. Didn't help.
I checked HTTPs tab > "clear server certs on exit".  This seems to be where ewseditor was able to connect with Fiddler capturing, but I had already manually removed them from the cert store, and removed them in HTTPs tab > Actions, and I have since unchecked it.  After each change I restarted ewseditor, and Fiddler, or just re-started Fiddler capture.  

At this point EWSeditor was able to connect, and sessions were recorded in Fiddler, but the sessions weren't getting https decrypted even though I had  "Decrypt HTTPS traffic." checked and   "... from all processes." selected (Error: "Fiddler's HTTPS Decryption feature is enabled, but this specific tunnel was configured not to be decrypted. Settings can be found inside Tools > Fiddler Options > HTTPS.")

This thread,"https://groups.google.com/forum/#!category-topic/httpfiddler/ALyM0Iq1slU", helped me fix that by "Click Tools > Fiddler Options > HTTPS. Untick "Decrypt HTTPS traffic." Push the "Remove Interception Certificates" button. Accept all prompts. Retick "Decrypt HTTPS traffic." Accept all prompts.", and then toggling capture.
Tags
Windows
Asked by
matt
Top achievements
Rank 1
Answers by
Eric R | Senior Technical Support Engineer
Telerik team
matt
Top achievements
Rank 1
Share this question
or