Exception at LaunchBrowser

Thread is closed for posting
3 posts, 1 answers
  1. Kangle Yu
    Kangle Yu avatar
    3 posts
    Member since:
    Nov 2009

    Posted 04 Apr 2010 Link to this post

    I downloaded the latest version of WebAii from the official site of ArtOfTest, and installed it for testing. it failed when i running following code:
                // Initialize the settings you want used.
                Settings mySettings = new Settings(BrowserType.InternetExplorer, @"d:\log\");

                // Create the manager object
                Manager myManager = new Manager(mySettings);

                // Start the manager
                myManager.Start();

                // Launch a new browser instance. [This will launch an IE instance given the setting above]
                myManager.LaunchNewBrowser(BrowserType.InternetExplorer, true);

                // Navigate to a certain web page
                myManager.ActiveBrowser.NavigateTo("http://www.google.com");

                // Perform your automation actions.
                Element mybtn = myManager.ActiveBrowser.Find.ByTagIndex("input", 3);
                myManager.ActiveBrowser.Actions.Click(mybtn);

                // Shut-down the manager and do all clean-up
                myManager.Dispose();
    it thrown a 'System.TimeoutException' at method LaunchBrowser(). I googled web for the solution as follow:
    1. Check your security policy regarding Named Pipes
    2. Disable any Internet Explorer plug-ins

    but all of this didn't work for me. it just open a blank IE, but never navigate to the target URL. 
    My environment information as follow:
    OS: Windows Vista Ultimate X86
    IE: IE 8.0
    WebAii Version: 2.0.9.0

    Any ideas?

    Regards,
    Sevolution
  2. Answer
    Missing user
    Missing user avatar

    Posted 05 Apr 2010 Link to this post

    Hello Kangle,

    Thanks for the post and your research on the issue. Just to confirm, if you can please make sure IE 8 is configured as in this documentation.

    Also, if you can please make sure UAC is turned completely off Windows Vista. And please make sure you are running the test with a user account that is part of the Admin Group for the machine.

    Let us know if you are still running into this problem after trying the above.

    Regards,
    Nelson Sin
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Kangle Yu
    Kangle Yu avatar
    3 posts
    Member since:
    Nov 2009

    Posted 06 Apr 2010 Link to this post

    Hi Nelson,

    Thanks for your suggestion. It works for me after do the following actions:

    1. Config IE8 settings as documents.
    2. Turn off UAC.

    Regards,
    Tom
Back to Top