Error 2103

6 posts, 0 answers
  1. Steve Sleeper
    Steve Sleeper avatar
    4 posts
    Member since:
    Oct 2009

    Posted 05 Nov 2009 Link to this post

    We are just getting started with Telerik and did the manual download (144 meg) of the newest demos.  The demos open fine in  VS 2008 with sp1.  They build fine.  When we run debug the browser gives the same error for all the demos except "example". 

    Line:54
    Char:13
    Error:  Unhandled Error in SL App
    Code: 2103
    Catagory:  Initialize Error
    Message:  Invalid or Malformed App Check Manifest
    Code:0

    This has happened on multiple machines with multiple browsers.
    What are we doing wrong?
  2. Vlad
    Admin
    Vlad avatar
    11100 posts

    Posted 05 Nov 2009 Link to this post

    Hi Steve,

    Generally this can happen with binaries with non-ASCII chars in file names however we don't have such. Can you provide more info about your environment?

    Sincerely yours,
    Vlad
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. Steve Sleeper
    Steve Sleeper avatar
    4 posts
    Member since:
    Oct 2009

    Posted 05 Nov 2009 Link to this post

    We have duplicated the error 2103 on two of our machines: a laptop and desktop.  Both are running Vista / VS / Expression Web & Blend.  The problem happens in Explorer and Firefox.  A couple of little apps were made without getting this error.  The demos all create this error.  Please let me know specific questions that would be helpful in diagnosing this problem.  Thanks for your assistance.    
  4. Steve Sleeper
    Steve Sleeper avatar
    4 posts
    Member since:
    Oct 2009

    Posted 05 Nov 2009 Link to this post

    ...just a quick follow up:  we duplicated the problem on a third machine.  Let me know what other info would be helpful.

    Thanks,
    Steve
  5. Steve Sleeper
    Steve Sleeper avatar
    4 posts
    Member since:
    Oct 2009

    Posted 05 Nov 2009 Link to this post

    The examples demo worked so we looked closely at it.  In Project/Properties/Silverlight:  When Startup Object is set to Telerik.Windows.Examples.App everything works.  When we change it to "Not Set" we get Error 2103 just like all the other demos.  All the other demos have Startup Object set to "Not Set".  I don't know how to set a file as the startup? 

    Thanks,

    steve
  6. Milan
    Admin
    Milan avatar
    1989 posts

    Posted 11 Nov 2009 Link to this post

    Hi Steve Sleeper,

    Our Silverlight samples should be started from the ExamplesWeb project - this is the entry point of our QuickStart application. All example project located in the Examples folder are unable to work on their own. We should probably provide more information about compiling and running our examples project.

    To run our demo application just set the ExampleWeb project as startup project and the Default.aspx page as start page. After that you should be able to run the demo application without any problems.

    Thank you for your feedback. We will try to provide documentation on this subject to make it easier for users to compile and run our samples.


    Greetings,
    Milan
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Back to Top