Capture traffic going to remote server on port 7047

2 posts, 0 answers
  1. bruce
    bruce avatar
    3 posts
    Member since:
    Nov 2010

    Posted 29 Sep 2017 Link to this post

    Hi,

     

    This must have been asked before !! ( so sorry about that )

     

    I'm making calls to a remote server which has a web service (soap based) on port 7047.

    I'm using soap ui to trace the call, but unless it goes via port 80 it does not get captured.

    Is there a way to tell fiddler to listen not to 80 but some other port 

    Thnaks

  2. bruce
    bruce avatar
    3 posts
    Member since:
    Nov 2010

    Posted 29 Sep 2017 in reply to bruce Link to this post

    OK So if anyone else has the same question I've sorted it out and here is what / why etc.

    Firstly. I was trying to debug a call I was making to a remote web service running on port 7047 on https.

    The test client is was using was SOAP UI

    To get soap ui to work with fiddler you need to set soap ui to point at the fiddler proxy port.

    Yes, obvious when you know, but as all the browsers i was initially using were picked up and their requests intercepted it did not cross my mind that i needed to do this.

    To set up the soap ui options details here

    https://kickingtech.wordpress.com/2014/05/15/getting-fiddler-to-work-with-soapui/

    In addition I was writing code that was running as a service and the service was making calls.

    I'm running on windows 10 and if you google then there are options described here..

    http://www.telerik.com/blogs/capturing-traffic-from-.net-services-with-fiddler

    or the other option which I took was to run the service under my account and the magic that fiddler does to capture my account traffic picked up the calls also.

    Hope this helps.

Back to Top