Can't find link by Id

3 posts, 0 answers
  1. Hugo
    Hugo avatar
    5 posts
    Member since:
    Oct 2012

    Posted 06 Nov 2012 Link to this post


    Been encountering a strange error, after I login a user I can't find a link, but If I enter with the user already logged in it finds the same link.

    The Id is always the same, and the link is visible.

    I had the same error on another test, where it I couldn't find a link, even Find.AllByTagName would not return all the "a" tags on the page.

    In that case the the test was making a search, the term was unique and you would be sent to the item page automatically, the link was there  but wasn't found. I got around it by searching by a non unique term, then clicking the results opening the page.

    Any ideas?

    Thanks in advance,
  2. Hugo
    Hugo avatar
    5 posts
    Member since:
    Oct 2012

    Posted 07 Nov 2012 Link to this post

    It only happens in FireFox and solved it the way I did the other problem I had with the checkboxes, by playing with the delays and timeouts in the settings.
  3. Boyan Boev
    Boyan Boev avatar
    1072 posts

    Posted 08 Nov 2012 Link to this post

    Hello Hugo,

    I am happy to hear you solved the problem. 

    Please let us know if you have additional questions or need further assistance.

    All the best,
    Boyan Boev
    the Telerik team

    Are you enjoying Test Studio? We’d appreciate your vote in the ATI automation awards. 
    Vote now

Back to Top