Authentification no more works with new proxy

1 posts, 0 answers
  1. Christian
    Christian avatar
    1 posts
    Member since:
    Jan 2017

    Posted 17 Jan 2017 Link to this post

    Hello,

    To start, let me say I love Fiddler, and have been using it for many years, as I most of the time develop web sites, and so on.

    My concern is that at my new work, they are using a f*** proxy with windows authentication, which make very hard to access internet for applications like maven, nodejs, and so on. I just start Fiddler, use localhost:8888 as proxy, and it automatically authenticate on the proxy, which is marvelous :)

    All worked fine using Fiddler with "Automatically Authenticate" for several months, until they change the proxy a month ago, and it no more works, but I can't figure why it does not work anymore.

    When I start FIddler, I always get the same error for each requests, maybe someone can help:

    10:51:14:0770 Automatic authentication of Session #3 was unsuccessful. System.Exception AuthenticationManager.Authenticate returned null.
       à Fiddler.Session.ž() dans c:\JenkinsHome\jobs\FiddlerReleaseBuild\workspace\Fiddler2\Common\Core\Session.cs:ligne 4263

    I haven't seen anything special in the request or response, except a line in the response: "Proxy-Support: Session-Based-Authentication" and the lack of Negotiate, but I'm not sure this is related. And even if Basic seems supported, it does not work, as if it has been disabled on proxy side.

    This is really anoying, I'll be happy to help if tests are needed on my side.

    Just to have more information, this is the dialog:

    > Request 1

    GET ...

    > Response 1

    407
    Proxy-Connection: Keep-Alive
    Proxy-Authenticate: NTLM
    Proxy-Authenticate: Basic realm="McAfee Web Gateway"
    Proxy-Support: Session-Based-Authentication

    > Request 2

    GET
    Proxy-Authorization: Negotiate TlRMTVNTUAABAAAAl4...AAAAAAAAAAAGAbEdAAAADw==

    > Response 2

    407
    Proxy-Connection: Keep-Alive
    Proxy-Authenticate: NTLM
    Proxy-Authenticate: Basic realm="McAfee Web Gateway"
    Proxy-Support: Session-Based-Authentication

    > Request 3

    GET
    Proxy-Authorization: NTLM TlRMTVNTUAABAAAAB7IIogMAAwAzAAAACwALACgAAAAGAbEdAAAAD0ZSMDU1NzM2MzZMRVVS

    > Response 3

    407
    Proxy-Authenticate: NTLM TlRMTVNTUAACAAAABgAGA...qXDSAQAAAAA=
    Proxy-Support: Session-Based-Authentication

    > Request 4

    Proxy-Authorization: NTLM TlRMTVNTUAADAAAAGAAYA.longer_than_previous.AAAAAAAAAAAAAAAA==

    > Response 4

    403 AuthorizedOnly

    it's over, error page with proxy error

     

    In previsous successfull dialog with th server, I got :

    > Response 1

    407
    HTTP/1.1 407 Proxy Authentication Required
    Proxy-Authenticate: NEGOTIATE
    Proxy-Authenticate: NTLM
    Proxy-Authenticate: BASIC realm="realm_natto"

    > Request 2

    Proxy-Authorization: Negotiate TlRMTVNTUA...ADw==

    > Response 2

    HTTP/1.1 407 Proxy Authentication Required
    Proxy-Authenticate: NEGOTIATE TlRMTVNTUAA...AcACABRPHpAqXDSAQAAAAA=

    > Request 3

    Proxy-Authorization: Negotiate TlRMTVNTUAADAAA...pKUzcq6X

    > Response 3

    it works, the reponse is good

    Regards and thanks to have read all long...

     

Back to Top