App won't load correctly after first install (Android)

3 posts, 1 answers
  1. Jonathan
    Jonathan avatar
    7 posts
    Member since:
    Aug 2013

    Posted 30 Sep 2014 Link to this post

    I have an app on cordova 3.5 that I'm developing using the AppBuilder. 
    when I install it on an Android device (Samsung GT-S7710, Android 4.1.2),
    the app loads but about half of my javascript files is not found on the device.
    (i have found out about this while using jsHybugger, it shows several 404 Errors in the DevTools)

    However, when i use LiveSync to reload the app afterwards, everything loads perfectly and the files get loaded like they should.

    I tried setting the used cordova version to 3.2 and 3.0 but nothing changed.
    I also gave my app ALL permissions available through the AppBuilder Project Settings without avail.
    Last thing I tried was setting the Build Settings to release, but that didn't help either.

    I redeployed the app after every single step mentioned above.

    I have attached a photo of the app not working and a logcat

  2. Answer
    Tina Stancheva
    Tina Stancheva avatar
    3299 posts

    Posted 02 Oct 2014 Link to this post

    Hi Jonathan,

    This issue is caused by the names of a few folders in your project structure. The Android Asset Packaging Tool (aapt) omits the folders starting with "_" and their content accordingly. There is actually an issue logged in the google issues board discussing this behavior.

    The live sync implementation, on the other hand, does not omit these folders and allows you to download them from the cloud to your device. However, in order to have such folders and their contents properly installed on an Android device, I would recommend reconsidering their names.

    Tina Stancheva

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

  3. Jonathan
    Jonathan avatar
    7 posts
    Member since:
    Aug 2013

    Posted 06 Oct 2014 in reply to Tina Stancheva Link to this post

    Hi Tina,

    i really had some folders named "__lib" and the like, renaming them into something without underscores did the trick!

    Huge thanks to you!
Back to Top