Fiddler firewall rule

3 posts, 0 answers
  1. Franz
    Franz avatar
    2 posts
    Member since:
    Jan 2019

    Posted 29 Jan Link to this post

    Hello there. I cannot seem to activate my Office 365 Business desktop application I recently installed on my machine. I have tried quite a few trials and errors nothing work until I decided to run Fiddler to monitor http traffic to and from the machine during activation process. But lo and behold, this time it activated immediately. I don't know exactly what happened but my suspicion is that fiddler creates its own firewall rule as part of its component to open up and provide access http traffic to and from the machine in question. Is this feasible?? I am really clueless at this point other than the fact that during the process of running fiddler trace I was able to activate my Office 365 Business desktop application. Any input, ideas or suggestions is greatly appreciated. Let me know please. Thanks!
  2. Simeon
    Admin
    Simeon avatar
    195 posts

    Posted 04 Feb Link to this post

    Hello Franz,

    You are right. If your user has administrative rights, during the installation, the FiddlerSetup executes the following command:
    netsh advfirewall firewall add rule name="FiddlerProxy" program="$INSTDIR\Fiddler.exe" action=allow profile=any dir=in edge=deferuser protocol=tcp description="Permit inbound connections to Fiddler"
    This allows you to debug traffic from other machines, if you select the 'Allow remote computers to connect' option from the Fiddler options.
    However, how the activation process of the Office 365 app works and why it does not work without Fiddler in your case is out of my scope.

    Regards,
    Simeon
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Franz
    Franz avatar
    2 posts
    Member since:
    Jan 2019

    Posted 04 Feb in reply to Simeon Link to this post

    Thank you for your reply. I appreciate it. Have a great day!
Back to Top