VS2008 Toolbox Error - Q3 2007

31 posts, 0 answers
  1. Brad
    Brad avatar
    110 posts
    Member since:
    Jun 2004

    Posted 18 Dec 2007 Link to this post

    During the installation of "RadControls for WinForms" on a machine that only has VS2008 Pro installed, I receive the following error:

    "ToolBox has encountered a problem and needs to close.  We are sorry for the inconvenience."

    After the install I have to then manually add the controls to the toolbox...
  2. Dimitar Kapitanov
    Admin
    Dimitar Kapitanov avatar
    632 posts

    Posted 19 Dec 2007 Link to this post

    Hello Brad,

    We verified the problem and it will be fixed for the next release. Thank you for the valuable feedback.

    Sincerely yours,
    Dimitar Kapitanov
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. UI for WinForms is Visual Studio 2017 Ready
  4. Chris Ruegsegger
    Chris Ruegsegger avatar
    46 posts
    Member since:
    Mar 2004

    Posted 19 Dec 2007 Link to this post

    I am also having this problem and I've submitted a support ticket with the ToolBox installer log file for your review.

    Chris
  5. Dimitar Kapitanov
    Admin
    Dimitar Kapitanov avatar
    632 posts

    Posted 20 Dec 2007 Link to this post

    Hi Chris Ruegsegger,

    Thank you for writing.

    Indeed we verified this behavior. It occurs on systems that have only VS2008 installed. It is fixed already and will be introduced in some of the upcoming releases. You can manually add all the required assemblies.

    Sorry for the inconvenience. If you have any additional questions, please contact us.

    Kind regards,
    Dimitar Kapitanov
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  6. Jeff
    Jeff avatar
    5 posts
    Member since:
    Jun 2007

    Posted 24 Jan 2008 Link to this post

    And how do you manually add them?
  7. Jeff
    Jeff avatar
    5 posts
    Member since:
    Jun 2007

    Posted 24 Jan 2008 Link to this post

    Right click toolbox area and select add items, check off telerik items worked ...
  8. Nikolay
    Admin
    Nikolay avatar
    1803 posts

    Posted 25 Jan 2008 Link to this post

    Hi Jeff,

    You are correct. This is one of the ways to manually add Telerik Controls to the Visual Studio Toolbox. For more information, please refer to our Knowledge Base article: Manually add RadControls for WinForms to the VS Toolbox.

    Best wishes,
    Nikolay
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  9. Brad
    Brad avatar
    110 posts
    Member since:
    Jun 2004

    Posted 09 Feb 2008 Link to this post

    The problem has not been fixed!

    I just installed Q3 2007 + SP1 and the same error occurred..

    When will this problem be fixed?  (You know, Really!)
  10. Nikolay
    Admin
    Nikolay avatar
    1803 posts

    Posted 11 Feb 2008 Link to this post

    Hi Brad,

    Thank you for bringing our attention to this issue.

    There seems to be a specific case where adding our WinForms controls to the Visual Studio 2008 Toolbox still does not work properly. We will continue investigating this issue. For the time being you can add them manually. Our Knowledge Base article will give you additional information: Manually add RadControls for WinForms to the VS Toolbox

    If we can be of your further assistance, do not hesitate to contact us.

    All the best,
    Nikolay
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  11. Greg
    Greg avatar
    20 posts
    Member since:
    Jul 2005

    Posted 06 Mar 2008 Link to this post

    This must be a bigger buggaboo then was first thought.  It is still a problem in Q3 2007 SP2.

    Thanks,

    Kuba
  12. Brad
    Brad avatar
    110 posts
    Member since:
    Jun 2004

    Posted 08 Mar 2008 Link to this post

    Hi Kuba,

    I think you will find that WinForms is still at Q3 2007 SP1.

    What I don't understand is why telerik can't integrate the fix that Dimitar Kapitanov reported (in this thread) on 12/20/2007?

    Cheers,
    Brad
  13. Nikolay
    Admin
    Nikolay avatar
    1803 posts

    Posted 10 Mar 2008 Link to this post

    Hello Brad,

    Actually, this issue was addressed and it no longer appears on Windows XP. However, we subsequently discovered that it still occurs on Windows Vista. We will continue to investigate its causes, but I cannot give you a specific time-frame when the issue will be addressed for Windows Vista.

    If you have any additional questions, please contact us.

    All the best,
    Nikolay
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  14. Brad
    Brad avatar
    110 posts
    Member since:
    Jun 2004

    Posted 10 Mar 2008 Link to this post

    Hi Nikolay,

    Can you please clarify something for me?  Is the XP fix supposed to be in the current release (Q3 2007 SP1)?

    Because I am currently using XP and still receiving the same error..

    Thanks,
    Brad
  15. Nikolay
    Admin
    Nikolay avatar
    1803 posts

    Posted 13 Mar 2008 Link to this post

    Hi Brad,

    Yes, registering the RadControls for WinForms in the VS 2008 Toolbox is implemented in the Q3 2007 SP1.

    We tested this functionliaty, and while the Q2 2007 controls suite did not register in the VS 2008 Toolbox, Q3 SP1 behaved as expected - the controls were in the Toolbox following installation. Please you can give me additional information on the following points:
    1. Your operating system version (including the Service Pack)
    2. Visual Stuidio versions (including the Service Pack if any)
    3. Visual Studio installation history. For example, currently you may have only VS 2008 installed, but whether VS 2005 was installed at a point in the past.  
    4. Whether there are some sort of system restrictions.

    We will continue to investigate the issue, but since there are many specifics, I can't give you a certain time-frame when your exact case would be solved.

    Regards,

    Nikolay
    the Telerik team


    Instantly find answers to your questions at the new Telerik Support Center
  16. Greg
    Greg avatar
    20 posts
    Member since:
    Jul 2005

    Posted 14 Mar 2008 Link to this post

    Hi Brad,

    Thanks for the correction.  That's not the first time I've done that when Winforms version gets out of sync with the others. 

    As far as the issue, I guess I should have mentioned that I do run in Vista (SP1), and it does occur as stated. 

    Luckily, dragging and dropping them into a new tab seems to work just fine, but it would be nice to see little things like this fixed.

    By the way... and this is to the Telerik developers... Thanks for the Status bar control that matches the form thesmes.  I brought this up over in the wish list.  Gotta love the little things!  :)

    Kuba
  17. Brad
    Brad avatar
    110 posts
    Member since:
    Jun 2004

    Posted 14 Mar 2008 Link to this post

    Hi Nikolay,

    Q1. Your operating system version (including the Service Pack)
    A1. Windows XP + SP2

    Q2. Visual Stuidio versions (including the Service Pack if any)
    A2. Visual Studio 2008 Pro Only!

    Q3. Visual Studio installation history. For example, currently you may have only VS 2008 installed, but whether VS 2005 was installed at a point in the past.
    A3. Visual Studio 2008 Pro was installed on a clean VM (Virtual Machine).  So no previous versions of Visual Studio have ever been installed on this machine.

    Q4. Whether there are some sort of system restrictions.
    A4. No Restrictions, I am running with Administrative Privileges.

    Regards,
    Brad
  18. Nikolay
    Admin
    Nikolay avatar
    1803 posts

    Posted 20 Mar 2008 Link to this post

    Hi Brad,

    I've tested your case - installed VS 2008 on a clean WinXP SP2 Virtual Machine. The WinForms controls were installed into the Toolbox as expected. We cannot localize the obstacle which prevents the controls from being registered into the Toolbox and therefore I cannot resolve this specific issue. As soon as you are able to give us information about the probable cause, please report it back. This will surely help us to address to issue properly and accurately.

    If you have additional questions, do not hesitate to contact us.

    Kind regards,
    Nikolay
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  19. Brad
    Brad avatar
    110 posts
    Member since:
    Jun 2004

    Posted 16 Apr 2008 Link to this post

    Hi,

    I just installed Q1 2008 and received an error during the installation: "ToolBox has encountered a problem and needs to close.  We are sorry for the inconvenience."

    System:
    Windows XP + SP2 (Virtual Machine)

    Current Software:
    Microsoft Visual Studio 2008 Pro
    Microsoft Windows SDK v6.0A
    Microsoft Visual Studio 2008 SDK
    Microsoft Visual SourceSafe
    Microsft SQL Server 2005 Developer Edition
        Microsoft Visual Studio 2005 (Cut down version that comes with SQL Server)
    Steema TeeChart for .NET v3 (.NET Controls)
    DotNetMagic (.NET Controls)
    TortoiseSVN

    Any ideas why I'm still getting this error?

    Thanks,
    Brad
  20. Alex Peachey
    Alex Peachey avatar
    56 posts
    Member since:
    May 2006

    Posted 17 Apr 2008 Link to this post

    I'm getting this as well and I think the culprit is SQL Server 2005 with the stripped down version of VS 2005 it installs.

    This is a very common item for just about any developer to have on their system so I'm surprised Telerik hasn't tested this configuration.

    I believe what happens in cases where you have:
    1. VS 2008 as the only full VS installed.
    2. SQL 2005 with the stripped down VS 2005 used for SQL dev work.

    The Telerik installer sees VS 2005 (or what it thinks is VS 2005) and it tries to install the controls in the toolbox. Alas, it's not the full version of VS 2005 and it chokes and fails. It then figures, well that didn't work and doesn't even look for or try the install on the VS 2008 toolbox.

  21. Brad
    Brad avatar
    110 posts
    Member since:
    Jun 2004

    Posted 20 Apr 2008 Link to this post

    Hi Alex,

    Thanks for your reply.  That sounds like a very plausible assumption.  I did get the same error on previous versions with only VS2008 installed but that is supposedly fixed.  Hopefully we can get some kind of confirmation from Telerik.

    Cheers,
    Brad
  22. Nikolay
    Admin
    Nikolay avatar
    1803 posts

    Posted 21 Apr 2008 Link to this post

    Hello guys,

    Thank you both for the additional information. It will surely help us further.

    We will research this case and will address the issue for one of our future releases.

    All the best,
    Nikolay
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  23. Andrea
    Andrea avatar
    64 posts
    Member since:
    Jan 2005
  24. Brad
    Brad avatar
    110 posts
    Member since:
    Jun 2004

    Posted 31 Jul 2008 Link to this post

    Hi Andrea,

    I first reported this problem almost eight months ago now. Personally I don’t think they have any kind of workable solution, else they would have deployed it already.

    Regards,
    Brad
  25. Nikolay
    Admin
    Nikolay avatar
    1803 posts

    Posted 31 Jul 2008 Link to this post

    Hi all,

    Andrea, by "reduced VS2005" I suppose you mean the Express version. Currently, we do not support automatic registration of the our controls into the ToolBox of Express or scaled down versions of Visual Studio.

    Guys, as to the issues you have with the full versions of Visual Studio, we are aware of them, but they cannot be addressed using the current installer. What should be done in this case is to switch to another installer package in the future. This will allow support of Express versions as well. Unfortunately, this is a major change, and I cannot give you a specific time frame when this will be addressed.

    Best wishes,
    Nikolay
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  26. Brad
    Brad avatar
    110 posts
    Member since:
    Jun 2004

    Posted 31 Jul 2008 Link to this post

    Hi Nikolay,

    As stated several times throughout this thread. We are not discussing an issue caused by the Express version but the crippled version of Visual Studio that ships with SQL Server. It seems that having the crippled version installed along with the full one prevents your installer from automatically adding controls to the toolbox.

    Regards,
    Brad
  27. Nikolay
    Admin
    Nikolay avatar
    1803 posts

    Posted 01 Aug 2008 Link to this post

    Hello Brad,

    We will investigate the issue that you describe in your last post. It will be addressed in the new installer, which we are integrating. However, as I mentioned before, I cannot give you a time frame when the new installer will be implemented.

    Best wishes,
    Nikolay
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  28. Andy
    Andy avatar
    2 posts
    Member since:
    Jan 2009

    Posted 29 Jan 2009 Link to this post

    I'm still having this happen with Q3 2008 SP2.

    I'm pretty sure Alex and Brad are right:  I have VS2008 (full install) and SQL Server 2005 Management studio installed which installs the Visual Studio 2005 IDE/shell which I believe is what SSMS is running in. 

    Just the IDE is there and the RadControls installer thinks the development tools are installed.  It then shows the option to add RadControls to 2008 and 2005 but since the dev parts of 2005 aren't there (including the toolbox) it errors on trying to add to that toolbox.

    I'm about to try a reinstall and will be sure to de-select the 2005 option and see if it goes through ok and if it finishes in 2008 ok.

    What the installer is looking at to decide whether to show the 2005 choice is wrong.  I've seen somewhere on the web how to look at what VS2005 components (VB.NET, C#.NET, etc.) are installed NOT just whether VS2005 is there: that's probably what it should be doing.  Or just check to see if the thing you change for the toolbox is there (registry hive?).  try/catch...


  29. Andy
    Andy avatar
    2 posts
    Member since:
    Jan 2009

    Posted 29 Jan 2009 Link to this post

    Even after unselecting 2005 in the install options I still got the error...

  30. Jordan
    Admin
    Jordan avatar
    547 posts

    Posted 30 Jan 2009 Link to this post

    Hi all,

    Thank you for all the information and feedback.

    Currently the toolbox installer that we are using always tries to install the controls in the VS toolbox.
    We will change that for our next release (which is Q1 2009). Also we are considering using another approach for installing the controls in the VS toolbox that will work in more cases that the current one.

    Do not hesitate to write me back if you have more questions.

    Regards,
    Jordan
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  31. Frank Do
    Frank Do avatar
    1 posts
    Member since:
    Jun 2009

    Posted 10 Aug 2009 Link to this post

    I am trying to install WinForms Q1 2009 into my VS2008 SP1 XP machine and getting this same exact error.  Toolbox has encountered a problem....  However, the install ran successfully but no telerik controls are added to vs2008.  Are we still in the process of fixing this in the next release?
Back to Top
UI for WinForms is Visual Studio 2017 Ready