Test studio Storage service setup

13 posts, 0 answers
  1. James
    James avatar
    9 posts
    Member since:
    Aug 2014

    Posted 15 Oct 2014 Link to this post

    Does any one seen a problem with installing Storage service for Test Studio. I've been trying to install Test Studio Storage services and keeps getting error:
    'Service 'Telerik Storage Service' (Telerik Storage Service) failed to start. Verify that you have sufficient privileges to start system services.' This error popup while it is try to do SQLExpress installation.

    I have check with my DevOps and he said I have Admin priviledges for my machine and also the VM  windows 7 machine that I am trying to setup. Is there a known issues that I am not aware of or is there any setup docs that would help would be great.

    Thank you,

    JamesNG
  2. Cody
    Admin
    Cody avatar
    3360 posts

    Posted 16 Oct 2014 Link to this post

    Hi James,

    Installing our storage service is not normally this difficult. One thing I can say for certain is that the error message "Service 'Telerik Storage Service' failed to start" is only displayed after SQL Express is successfully installed and our installer is trying to start our service, which then makes a connection to SQL Server. If there's any problem connecting to SQL Server you will get this error.

    Usually when this error happens there's also an error logged in the Windows Event Viewer (in the Applications log). Can you have a look in there and see if there's more details about this error you are getting?

    One other question, are you configuring it to connect to the default local installation of SQL Express or configuring to connect to an external SQL Server box?

    Regards,
    Cody
    Telerik 
  3. James
    James avatar
    9 posts
    Member since:
    Aug 2014

    Posted 16 Oct 2014 in reply to James Link to this post

    Hi Cody, I am taking the default local installation of SQL Express. I've looked at the event viewer log and it just showing that the Storage service failed to start. I am including the installation log that Test studio created.

    please advice,


    event viewer log:
    Log Name:      Application
    Source:        gupdate
    Date:          10/16/2014 1:31:21 AM
    Event ID:      0
    Task Category: None
    Level:         Information
    Keywords:      Classic
    User:          N/A
    Computer:      CI02
    Description:
    The description for Event ID 0 from source gupdate cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.If the event originated on another computer, the display information had to be saved with the event.The following information was included with the event: Service stoppedEvent Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="gupdate" />
        <EventID Qualifiers="0">0</EventID>
        <Level>4</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2014-10-16T08:31:21.000000000Z" />
        <EventRecordID>43637</EventRecordID>
        <Channel>Application</Channel>
        <Computer>CI02</Computer>
        <Security />
      </System>
      <EventData>
        <Data>Service stopped</Data>
      </EventData>
    </Event>
  4. Cody
    Admin
    Cody avatar
    3360 posts

    Posted 16 Oct 2014 Link to this post

    Hi James,

    Thank you for that information and the log. Unfortunately it doesn't tell us anything more that we didn't already know. It doesn't give us any reason as to why the storage service failed to start up properly.

    I'd like to look at this problem on your machine via GoToMeeting. Let me know what timezone you're in and your availability and I'll setup the meeting.


    Regards,
    Cody
    Telerik 
  5. James
    James avatar
    9 posts
    Member since:
    Aug 2014

    Posted 16 Oct 2014 in reply to Cody Link to this post

    Hi Cody, Thanks for looking at my issue. I've also looked at the logs and talked to my DevOps and he said that I am logging in with Admin priviledges so not sure why windows can't start the Telerik storage services. I've tried to installed Telerik storage services on my windows 7 work station and on my Windows 7 VM both with same error while setup going thru installing local SQLExpress.

    I am in California San Diego PST times. would it be ok if we could do Go ToMeeting some time early next week say Monday or Tuesday. Let me know what the date and time you can do this would be great.

    Thanks,

    James
  6. Cody
    Admin
    Cody avatar
    3360 posts

    Posted 16 Oct 2014 Link to this post

    Hi James,

    I agree, the symptoms and the contents of the logs do not indicate a permissions issue. Something else is going on that we don't yet understand. But I am confident I'll be able to figure it out once I get a look at your machine.

    No problem scheduling our meeting for next week, how about 11am PDT:

    1.  Please join my meeting, Monday, October 20, 2014 at 1:00 PM Central Daylight Time.
    https://global.gotomeeting.com/join/816936589

    2.  Use your microphone and speakers (VoIP) - a headset is recommended.  Or, call in using your telephone.

    Dial +1 (571) 317-3112
    Access Code: 816-936-589
    Audio PIN: Shown after joining the meeting

    Meeting ID: 816-936-589



    Regards,
    Cody
    Telerik 
  7. Cody
    Admin
    Cody avatar
    3360 posts

    Posted 20 Oct 2014 Link to this post

    Hello James,

    Can we meet 30 minutes earlier (10:30 PDT)? I forgot about another appointment I have at my 1:30 pm, leaving us only 30 minutes to work your issue.

    Regards,
    Cody
    Telerik 
  8. James
    James avatar
    9 posts
    Member since:
    Aug 2014

    Posted 20 Oct 2014 in reply to Cody Link to this post

    Hi Cody, sure i can do 10:30 a.m.

    see you then.

    thanks,

    james
  9. Cody
    Admin
    Cody avatar
    3360 posts

    Posted 20 Oct 2014 Link to this post

    Hello James,

    It was a pleasure working with you today. Just to document the outcome of today's meeting, what we discovered is that you were attempting to change the install of Test Studio to add the Storage service. Unfortunately due to a known problem with our installer, this route does not install SQL Express, which is required by our storage service.

    Once we did a full uninstall, and re-install, which does install SQL Express, we got the storage service to start as expected.

    I also walked you through how to use the remote scheduling and storage service, and answered a question about performance testing.

    Regards,
    Cody
    Telerik 
  10. James
    James avatar
    9 posts
    Member since:
    Aug 2014

    Posted 20 Oct 2014 in reply to Cody Link to this post

    Thanks Cody for helping resolved the issue with Telerik storage services installation.
    I am now trying to download the runtime installation but not able to find it on Telerik website. could you shoot me the link so I can download and install the runtime?

    Thanks again for your help today.

    Best regards,

    JamesNg
  11. James
    James avatar
    9 posts
    Member since:
    Aug 2014

    Posted 20 Oct 2014 in reply to James Link to this post

    Nevermind Cody. I found it.

    thanks,

    james
  12. Cody
    Admin
    Cody avatar
    3360 posts

    Posted 20 Oct 2014 Link to this post

    Hello,

    Excellent! Thank you for the update.

    Regards,
    Cody
    Telerik 
  13. Andrew
    Andrew avatar
    5 posts
    Member since:
    Jun 2012

    Posted 06 Jul 2015 Link to this post

    I get this issue with every installation on every machine.  When the process fails to start during installation, simply go into your services on your windows machine and change the user from local system to a user with local administration on the service that is failing to start.

Back to Top