Stuck with errors after uninstalling test studio trial

2 posts, 0 answers
  1. THomas
    THomas avatar
    1 posts
    Member since:
    Aug 2016

    Posted 12 Oct Link to this post

    After installing Test Studio trial and unistalling again after the trial period has ended, I am left with an error message each time VS2015 Community Ed opens.

    "The 'WebAiiVSIP' package did not load correctly" which is detailed in VS error log:

      <entry>
        <record>53</record>
        <time>2016/10/12 06:33:12.006</time>
        <type>Error</type>
        <source>VisualStudio</source>
        <description>CreateInstance failed for package [WebAiiVSIP]Source: &apos;mscorlib&apos; Description: Could not load file or assembly &apos;file:///C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\PrivateAssemblies\ArtOfTest.WebAiiVSIP-VS2015.dll&apos; or one of its dependencies. Den angivne fil blev ikke fundet.&#x000D;&#x000A;System.IO.FileNotFoundException: Could not load file or assembly &apos;file:///C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\PrivateAssemblies\ArtOfTest.WebAiiVSIP-VS2015.dll&apos; or one of its dependencies. Den angivne fil blev ikke fundet.&#x000D;&#x000A;File name: &apos;file:///C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\PrivateAssemblies\ArtOfTest.WebAiiVSIP-VS2015.dll&apos;&#x000D;&#x000A;   at System.Reflection.RuntimeAssembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark&amp; stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)&#x000D;&#x000A;   at System.Reflection.RuntimeAssembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, RuntimeAssembly locationHint, StackCrawlMark&amp; stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)&#x000D;&#x000A;   at System.Reflection.RuntimeAssembly.InternalLoadAssemblyName(AssemblyName assemblyRef, Evidence assemblySecurity, RuntimeAssembly reqAssembly, StackCrawlMark&amp; stackMark, IntPtr pPrivHostBinder, Boolean throwOnFileNotFound, Boolean forIntrospection, Boolean suppressSecurityChecks)&#x000D;&#x000A;   at System.Reflection.RuntimeAssembly.InternalLoadFrom(String assemblyFile, Evidence securityEvidence, Byte[] hashValue, AssemblyHashAlgorithm hashAlgorithm, Boolean forIntrospection, Boolean suppressSecurityChecks, StackCrawlMark&amp; stackMark)&#x000D;&#x000A;   at System.Reflection.Assembly.LoadFrom(String assemblyFile, Evidence securityEvidence)&#x000D;&#x000A;   at System.Activator.CreateInstanceFromInternal(String assemblyFile, String typeName, Boolean ignoreCase, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes, Evidence securityInfo)&#x000D;&#x000A;   at System.AppDomain.CreateInstanceFrom(String assemblyFile, String typeName)&#x000D;&#x000A;&#x000D;&#x000A;WRN: Assembly binding logging is turned OFF.&#x000D;&#x000A;To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.&#x000D;&#x000A;Note: There is some performance penalty associated with assembly bind failure logging.&#x000D;&#x000A;To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].&#x000D;&#x000A;</description>
        <guid>{D5EDEC6D-8025-40CF-987C-B8EABA2C7451}</guid>
        <hr>80004005 - E_FAIL</hr>
        <errorinfo></errorinfo>
      </entry>

     

    So it looks like VS2015 is still looking for a component of Test Studio.

    The extension is completely uninstalled (not listed under extensions and the directory C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE does not contain any files or folders with Telerik in.

     

    I'm opening this support ticket as suggested by the Telerik team:

    Hey Thomas!

    I connected with my engineering team, and it appears this is something we haven’t come across before:

    This would indeed not be an expected crash and we failed to reproduce the problem on our side.

    Since you are still struggling though, it is possible that even after the uninstall there is a process still locking something. This exact package from the error message should be located here:

    C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\Extensions\Telerik\Test Studio

    Would you check for any left overs to remove there and also search in C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE for any similar files.

    In case there is nothing, then would you please restart the machine?

    If all this shows no result, my advice would be that you open a support ticket or a forum and share all details, so that that the support team could advice further.

    Kevin Kurbs
    Product Specialist, Test Studio


    Progress
    201 Jones Rd | Waltham, MA
    phone 1-857-702-4502
    mobile 1-978-875-4489
    twitter @KKurbs

  2. Boyan Boev
    Admin
    Boyan Boev avatar
    1043 posts

    Posted 14 Oct Link to this post

    Hello Thomas,

    It seems that Test Studio uninstaller did not remove our package from Visual Studio.

    Please try removing it manually:

    1. Open Visual Studio.

    2. Navigate to Tools -> Extensions and Updates

    3. Locate Test Studio packages and uninstall them.

    Let me know if that helps.

    Regards,
    Boyan Boev
    Telerik by Progress
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
Back to Top