Handle FileUpload dialog not working in Firefox

7 posts, 0 answers
  1. Steve
    Steve avatar
    11 posts
    Member since:
    Jul 2012

    Posted 09 May 2012 Link to this post

    I'm using the latest trial version of Test Studio and am building a proposal to use it for my company.

    I've written a simple test but can't get the FileUpload dialog to display in Firefox 12.0. The test just hangs. All other browsers work ok.
    I've ensured that the Firefox settings have been configured correctly.

    Any clues as to why I'm getting this error in Firefox:

    Timed out waiting '10000' msec. for any dialog to be handled '1'

    Cheers,
    Steve
  2. Anthony
    Admin
    Anthony avatar
    19 posts

    Posted 09 May 2012 Link to this post

    Hello Steve,

    I just tested an Upload scenario against this site and the test executed successfully in Firefox 12.

    Does the Click step never cause the dialog to launch? If so, try setting the Click step's SimulateRealClick property to True. You might instead record a Left Click Mouse Action step (from the Elements Menu) on the Browser/Upload button.

    If you continue to have difficulty, please provide more information to continue troubleshooting.

    Greetings,
    Anthony
    the Telerik team
    Quickly become an expert in Test Studio, check out our new training sessions!
    Test Studio Trainings
  3. Janani
    Janani avatar
    3 posts
    Member since:
    Jun 2015

    Posted 09 Jun 2015 in reply to Anthony Link to this post

    I am facing the exact issue that Steve was facing. And I tried the test case using the website that Antony suggested. Yes test playback works perfect with the given site but not with my application. In fact handle 'fileupload' dialog step fails even while testing file upload in telerik test studio. Did anyone come up with a solution for this?
  4. Janani
    Janani avatar
    3 posts
    Member since:
    Jun 2015

    Posted 09 Jun 2015 in reply to Janani Link to this post

    Sorry small correction - Handle 'FileUpload' dialog test step fails even while testing with telerik.com website
  5. Ivaylo
    Admin
    Ivaylo avatar
    750 posts

    Posted 12 Jun 2015 Link to this post

    Hello Janani,

    Please note that you are updating a post from 2012, it is very unlikely to experience the same issue, or at least the cause is different.

    Please submit a separate post including more information. The best way to proceed will be if you provide access to your application so I can investigate.

    Thank you for your understanding.

    Regards,
    Ivaylo
    Telerik
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
  6. Janani
    Janani avatar
    3 posts
    Member since:
    Jun 2015

    Posted 12 Jun 2015 in reply to Ivaylo Link to this post

    Hello Ivaylo,

    Thank you for responding. I found a solution using 'blind mouse click'. I submitted a ticket through my account and Telerik support team guided me well.

    Thanks again,

    Janani

     

     

     

     

  7. Ivaylo
    Admin
    Ivaylo avatar
    750 posts

    Posted 15 Jun 2015 Link to this post

    Hello Janani,

    Glad to hear you have found a solution. I am closing this case now.

    Regards,
    Ivaylo
    Telerik
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
Back to Top