DOM EXPLORER keeps loading then disconnect the app when recording an ios app

4 posts, 0 answers
  1. Rosie
    Rosie avatar
    1 posts
    Member since:
    Jul 2016

    Posted 22 Jul 2016 Link to this post

    I am trying to record an ios application. Connecting to the device successfully. But when I start recording the app, the DOM EXPLORER just keeps loading for a long time then disconnect the app itself. Could you please help me with this? I tried iPhone and iPad, neither of them can start recording.
  2. Elena Tsvetkova
    Admin
    Elena Tsvetkova avatar
    551 posts

    Posted 27 Jul 2016 Link to this post

    Hello Rosie,

    Based on your description it seems like the connection is lost after recording starts. This might be caused by many reasons, but most often it is due to:

    1. Wrong app configuration. Please verify that you exactly follow configure your application to be testable article. Note that when targeting iOS9 device, you have to ensure some additional details concerning the app identifier.
    2. Connection loss might also be caused by Wi-Fi connection settings. Have you tried recording using USB connection instead?
    3. Older version of Test Studio - please ensure that you are using latest version of the product.

    If none of the above helps, I am afraid that we will need a sample that replicates the problem. If your app contains a sensitive information, you can assemble a dummy app that replicates the issue and send it to us for investigation.

    Regards,
    Elena Tsvetkova
    Telerik by Progress
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
  3. Austin
    Austin avatar
    1 posts
    Member since:
    Sep 2015

    Posted 31 May Link to this post

    It seems that I have a similar problem; however I'm not testing a native app, but a website within Safari.

    Once I Connect via the Mobile Testing app, click Record and insert the URL, it passes the URL to Safari and then disconnects.

    I can't connect via USB because it requires iTunes.

    Any ideas?

  4. Elena Tsvetkova
    Admin
    Elena Tsvetkova avatar
    551 posts

    Posted 05 Jun Link to this post

    Hi Austin,

    Thank you for your interest in Test Studio Mobile. 

    Please ensure you have successfully configured Test Studio for web automation. 

    Next important step is to configure the Proxy on device, proceed with installing the certificate and then connect the Agent

    Please ensure you are trying to record a web test when trying to reach the page under test. 

    Please let me know if all of the above configuration steps were successfully performed but you continue experiencing the shared troubles. 

    Thanks in advance for your cooperation! 

    Regards,
    Elena Tsvetkova
    Progress Telerik
     
    The New Release of Telerik Test Studio Is Here! Download, install,
    and send us your feedback!
Back to Top