cjordan

9 posts, 0 answers
  1. Christopher
    Christopher avatar
    4 posts
    Member since:
    Feb 2011

    Posted 18 Feb 2011 Link to this post

    Hi everyone,

    I have looked throught many of the forum posts and other documentations pages to see if there is a known solution to my problem... I did not find anything, but that does not mean that I did not overlook it. Anyway... I'm relatively new to the programming world and I am currently taking some programming classes as Lone Star's Montgomery College, where, in one of my assignments, I am to use the Telerik Rad Controls for Windows Forms.  I downloaded and installed the trial software, but now that I have, I cannot create a new project in Visual Studio 2008.  At first I thought that it would be a simple fix by just uninstalling and reinstalling, but I still cannot create a project, nor can I even open any of my old projects.  When I try and open an old project, I simply get the error, "Unable to read the project file 'projectx.csproj'."  If I try and create a new project, it acts like it is going to, but in the status bar at the bottom of the VS window, it says, "Creating project 'WindowsFormsApplication1'... project creation failed."  I have a feeling that this is going to lead to me reinstalling VS but I'd like to avoid that if possible.  Has anyone ever experienced this before or have a possible solution to help me out... unfortunately my assignments are due on a fairly strict deadline so the sooner I could get some help, the better... really, I'd just appreciate any kind of help at this point.

    Thanks in advance,

    C Jordan
  2. Richard Slade
    Richard Slade avatar
    3000 posts
    Member since:
    May 2009

    Posted 18 Feb 2011 Link to this post

    Hi Christopher,

    Sorry to hear about your problems. This isn't one I've seen before but a quick Google search came up with the following MSDN blogs link. You should also check to make sure that the directories are not now read only.
    Hope that helps but let me know if you have furthe issues
    Richard
  3. UI for WinForms is Visual Studio 2017 Ready
  4. Christopher
    Christopher avatar
    4 posts
    Member since:
    Feb 2011

    Posted 18 Feb 2011 Link to this post

    Well, I tried the proposed solution... and I thought it worked... but I soon found out that I was wrong.  When I first tried the devenv /resetskippkgs solution, I was at least able to open an old project.  However, when I closed that project and opened Visual Studio again, I get a "Package Load Failure : Package 'Microsoft.Practices.ProjectLinker.ProjectLinkerPackage, ProjectLinker, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' has failed to load properly (GUID = {E8438F3E-AE3B-4318-AF42-04C4C3916239}). Please contact package vendor for assistance.  Application restart is recommended, due to possible environment corruption.  Would you like to disable loading this package in the future?  You may use 'devenv/ resetskippkgs' to re-enable package loading."  Regardless if I click Yes or No, I then get another "Package Load Failure : Package 'Telerik.CommonPackage.Telerik_CommonPackagePackage, Telerik.CommonPackage, Version=1.0.9.0, Culture=neutral, PublicKeyToken=d63abc9583eb6f32' has failed to load properly (GUID = {D4F5086C-54B9-4B07-BD22-AF72D5B9228F}). Please contact... (it finishes the same as the first Load Failure message)."  Again, regarless of what I choose, I get another Load Failure (for sake of space/time I won't retype that message, unless you think it would help), and then another one, and another one, and so on... totalling up to approximately 10 Package Load Failures.  If it would help, I could provide the details of the load failures (which all differ from one another, although most seem to pertain to Telerik)... but again, to save time (for now) I'm going to refrain from doing so.

    Actually, while I've been writting this, I've been messing with it in the background and now, regardless of wether or not I use the 'devenv /resetskippkgs', I still get all of the Load Failures, and I am still unable to open or create projects, so now I'm really confused... any ideas...?

    As far as the directories go, they are not read-only... I checked and double-checked just to make sure.
  5. Richard Slade
    Richard Slade avatar
    3000 posts
    Member since:
    May 2009

    Posted 19 Feb 2011 Link to this post

    Hi again,

    Don't worry. No need to post everything at the moment. I've been having a look around, and there are a few Telerik responses to this issue Please have a look at this response that makes suggestion and links to an excellent MSDN article.
    Hope that helps
    Richard
  6. Richard Slade
    Richard Slade avatar
    3000 posts
    Member since:
    May 2009

    Posted 21 Feb 2011 Link to this post

    Hello,

    Did this help? If so, please remember to mark as answer. If you need further help, just let me know.
    Thanks
    Richard
  7. Christopher
    Christopher avatar
    4 posts
    Member since:
    Feb 2011

    Posted 21 Feb 2011 Link to this post

    Sorry, I was away from the computer most of yesterday and part of the day before... my professor has been following this discussion, and as per his instructions, I just uninstalled everything (Telerik, Visual Studio, etc.) (partly because I was having SQL problems too).  I am upgrading to VS 2010 and once I get that installed and get SQL working properly, we (my instructor and I) will both work on getting Telerik put back on my machine.  Is there any reason why this version of the Rad Controls for WinForms would not work for VS 2008 but would work for VS 2010 (like was it designed with 2010 in mind), or (which I am assuming is probably the case) has it been tested with all versions of VS?

    Thank you,

    C Jordan
  8. Richard Slade
    Richard Slade avatar
    3000 posts
    Member since:
    May 2009

    Posted 21 Feb 2011 Link to this post

    Hello,

    Telerik RadControls for WinForms is compataible with VS 2008. If you're in doubt then do have a look at the System Requirements Page.
    Once you have everything re-installed, and if you have any further questions, then please ket me know
    Thanks
    Richard
  9. Christopher
    Christopher avatar
    4 posts
    Member since:
    Feb 2011

    Posted 21 Feb 2011 Link to this post

    Will do.  Thanks a lot for your help!

    C Jordan
  10. Stefan
    Admin
    Stefan avatar
    2890 posts

    Posted 23 Feb 2011 Link to this post

    Hi guys,

    Thank you both for writing.

    I just want to add something to this discussion. After reinstalling Visual Studio 2008/2010, please make sure that they both are not running while Telerik controls are being installed. Here is a help article describing the installation process.

    Let me know if you need further assistance.
     
    Kind regards,
    Stefan
    the Telerik team
    Registration for Q1 2011 What’s New Webinar Week is now open. Mark your calendar for the week starting March 21st and book your seat for a walk through all the exciting stuff we ship with the new release!
Back to Top
UI for WinForms is Visual Studio 2017 Ready