Theme resets to default when used in custom control for Lightswitch

3 posts, 0 answers
  1. Magnus
    Magnus avatar
    7 posts
    Member since:
    Mar 2013

    Posted 27 Oct 2016 Link to this post

    I am trying to change the theme on a radgridview.
    But it wont change when rendered as a customcontrol in lightswitch.

    For testpurpose I created a simple new Telerik Silverlight project with only one radgridview inside.
    Then I used Stylemanager to change the theme to Vista, and this works fine running just this.
    In a  Lightswitch screen I am adding a custom control by refering this silverlight control. 

    When running the Lightswitch application the gridview render and works fine, but the theme is changed back to the default theme "office black".

    Is it something I missed, or doing wrong?
    I have tried setting the theme both by Stylemanager and using Implicit Styles.
  2. Evgenia
    Evgenia avatar
    1418 posts

    Posted 01 Nov 2016 Link to this post

    Hello Magnus,

    I recommend that you make sure that all required Telerik assemblies are referenced in the LightSwitch project and more specifically the Telerik.Windows.Themes.Vista assembly. This is applicable for both StyleManager and Implicit styles theming mechanisms. There's just one major difference runtime if the theme assembly is missing -- with StyleManager it will fallback to the default OfficeBlack theme (as in your case) and with NoXAML binaries (required for Implicit styles theming mechanism) you won't see nothing runtime simply because there is no theme resource file to render your xaml from.

    Telerik by Progress
    Do you need help with upgrading your AJAX, WPF or WinForms project? Check the Telerik API Analyzer and share your thoughts.
  3. Burak
    Burak avatar
    1 posts
    Member since:
    Jan 2017

    Posted 3 days and 5 hours ago Link to this post

    Hi. I am using telerik and ı am getting this error. 


    On local computer it works but after publish It doesnt work. Can you help me ?

Back to Top