Startup performance

4 posts, 0 answers
  1. Kathleen
    Kathleen avatar
    19 posts
    Member since:
    Feb 2007

    Posted 21 Feb 2007 Link to this post

    I just started up an application with a RibbonBar and was suprised that it took about 15 seconds to load.

    Are there known load time issues or general suggestions for performance?
  2. Mike
    Admin
    Mike avatar
    640 posts

    Posted 22 Feb 2007 Link to this post

    Hi Kathleen,

    The load performance is degraded by the process that loads the predefined themes (themes that are supplied with our controls like Office2007Black or Office2007Silver for example). There are a lot of bulky XML files to be processed that load the theming for all instantiated UI element types like buttons, tabs, menus, etc. We are working on a major optimization of the performance and our latest achievements proved to be optimistic.
    In the case with the ribbonbar, we tested a scenario that includes a ribbonbar containing 50 chunks and more than 500 buttons. It takes up to 3 seconds for the application to start and the ribbonbar to be displayed on a average performance PC.
    There are still slight performance issues with the layout system but we are working on that one too. The rendering system also will be polished. We are also optimizing the memory footprint of our controls, you should expect a nice surprise there too.
    All mentioned above should be available in the next release. Any feedback on the topic is most welcome.

    Kind regards,
    Mike
    the telerik team
  3. UI for WinForms is Visual Studio 2017 Ready
  4. gerbrand
    gerbrand avatar
    78 posts
    Member since:
    Mar 2009

    Posted 28 Sep 2009 Link to this post

    Hi,

    I think I have the same problem here. Just wanted to test somethings so I added on the main form a ribbonbar (only a ribbonbar, no other controls yet on the form) and I have to say that the loading time is around 30seconds.
    I'm using visual studio 2008 sp1 on vista ultimate with the Q2 2009 version.

    Thanks




  5. Mike
    Admin
    Mike avatar
    640 posts

    Posted 01 Oct 2009 Link to this post

    Hello Gerbrand,

    The forum post concerns a much older versions of RadControls for WinForms and since then many things changes.

    Currently we do not have any similar performance issues reported, regarding RadRibbonBar or any other RadControl. Can you please specify any details about yor scenario so we can test it here. I also converted this post to "General Feedback" so you can attach any files if necessary.

    Sincerely yours,
    Mike
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Back to Top