RibbonBar not honoring Theme

10 posts, 0 answers
  1. Dan
    Dan avatar
    11 posts
    Member since:
    Feb 2012

    Posted 29 Mar 2012 Link to this post

    When a ribbon is added to my main form, the main window looses its theming for the title bar and window borders.

    Steps to reproduce:
    Version 2012.1.321.40 Trial
    Create a new project - make it a Telerik windows application.
    Drop the Office2010Black them on the form in the Designer.
    Add the following to your form constructor:

    public MainForm()
    {
    InitializeComponents();
    ThemeResolutionService.ApplicationThemeName = "Office2010Black";
    }

    Run the application.  Notice the tile bar is themed.  The thing looks nice.

    Now add a ribbon bar.
    Tell it that it is fine to add the behavior it wants to.
    Add a new tab and a new group.
    Run the application.

    Notice the title bar is no longer themed.  Basically it looks really ugly.  See the attached PNG file.

    What do I need to do to make the entire application honor the theming?

    Thanks in advance for your great support.


  2. Stefan
    Admin
    Stefan avatar
    2891 posts

    Posted 03 Apr 2012 Link to this post

    Hello Dan,

    Thank you for writing.

    The observed behavior is caused by the fact that your system have aero effects enabled. To overcome this behavior, please right click your project > Add > Windows Form. Select Telerik RadRibbonForm, which is a predefined RadForm with a ribbon. Set the form's AllowAero property to false and your title bar will be correctly themed. More information about RadRibbonForm can be found here: http://www.telerik.com/help/winforms/forms-and-dialogs-ribbonform-overview.html.

    I hope that the provided information addresses your question. Should you have any other questions, do not hesitate to contact us.
     
    Greetings,
    Stefan
    the Telerik team
    RadControls for WinForms Q1'12 release is now live! Check out what's new or download a free trial >>
  3. UI for WinForms is Visual Studio 2017 Ready
  4. Hussein
    Hussein avatar
    1 posts
    Member since:
    Nov 2011

    Posted 03 Aug 2012 Link to this post

    I have the same problem but without inheritance, I have stand alone radribbonform and I tried your solution and it still does not work. Before reading your solution I read a different solution by telerik suggesting the exact opposite of what you suggested and it also did not work. Basically the previous solution stated that we had to set allowaero to true instead of false.

    I have added to the code:
    ThemeResolutionService.ApplicationThemeName = "TelerikMetroBlue";

    Please assist because as you can see from the attached png, the ribbonform looks really ugly.

    Thanks!
  5. Stefan
    Admin
    Stefan avatar
    2891 posts

    Posted 08 Aug 2012 Link to this post

    Hello Hussein,

    Thank you for writing.

    On the image provided the aero effects for the ribbon form are allowed, thus the title bar looks transparent. To overcome this behavior you need to set the AllowAero property to false. Attached you can find images of the ribbon form with and without aero.

    I hope this helps.

    All the best,
    Stefan
    the Telerik team
    RadControls for WinForms Q2'12 release is now live! Check out what's new or download a free trial >>
  6. Mohsen
    Mohsen avatar
    13 posts
    Member since:
    Jan 2013

    Posted 04 Feb 2013 Link to this post

    Hi
    I use Telerik 2012 Q3 SP1 with Visual Studio 2012,Where is the AllowAero Property?(It was in the Q2 version but it seems removed from Q3 version!).
    I wanna disable windows 7 aero glass title bar in RadForm and show Telerik themes.how can I do it?

    Regards,
    Mohsen.
  7. Mohsen
    Mohsen avatar
    13 posts
    Member since:
    Jan 2013

    Posted 07 Feb 2013 Link to this post

    Everyone?
  8. Plamen
    Admin
    Plamen avatar
    132 posts

    Posted 08 Feb 2013 Link to this post

    Hello Mohsen,

    Thank you for writing.

    AllowAero property is specific for RadRibbonForm. I assume that you are talking about the AllowAeroGlass property of RadForm, which was replaced with AllowTheming in release Q2 2009. So, If you want to disable the Windows 7 aero glass effect for RadForm, you could set the AllowTheming property to true.

    I hope this helps.

    All the best,
    Plamen
    the Telerik team
    Q3'12 SP1 of RadControls for WinForms is out now. See what's new.
  9. Mohsen
    Mohsen avatar
    13 posts
    Member since:
    Jan 2013

    Posted 08 Feb 2013 Link to this post

    Sorry Plamen,
    I forgot to say that my problem is when a Ribbon bar add to RadForm,I try to set AllowAero property to True,but it doesn't changes.(Please see the attached picture)How can I fix this problem?(All of my forms contain Ribbonbars and I don't want to see windows aero glass theme.I want to see RadForm default title bar.)

    Regards,
    Mohsen.
  10. Plamen
    Admin
    Plamen avatar
    132 posts

    Posted 14 Feb 2013 Link to this post

    Hello Mohsen,

    Thank you for writing.

    To the questions at hand,
    1) When you place RadRibbonBar on RadForm and you enable the ribbon behavior, you could set the AllowTheming property to true to remove the aero effect:
    this.radRibbonFormBehavior1.AllowTheming = false;

    Alternatively, you could use RadRibbonForm instead and set its AllowAero property to false:
    this.AllowAero = false;

    In both cases, when you disable the aero effect, the RightToLeft mode should behave correctly:
    this.radRibbonBar1.RightToLeft = System.Windows.Forms.RightToLeft.Yes;


    I hope that you find this information useful.

    Regards,
    Plamen
    the Telerik team
    Q3'12 SP1 of RadControls for WinForms is out now. See what's new.
  11. Mohsen
    Mohsen avatar
    13 posts
    Member since:
    Jan 2013

    Posted 16 Feb 2013 Link to this post

    Great!
    Thank you Plamen.

    Regards,
    Mohsen.
Back to Top
UI for WinForms is Visual Studio 2017 Ready