Problems with Progressbar

4 posts, 0 answers
  1. ManniAT
    ManniAT avatar
    877 posts
    Member since:
    Nov 2003

    Posted 27 Mar 2008 Link to this post

    Hi,

    I try to build a splashscreen including radprogess.
    First I learned that after incrementing Value1 in a timer event I have to call Refresh - otherwhise the value is not updated visually.

    Next problem - reading the documentation I found some confusing things:
    "Background Color is used for the bar....".

    Anyhow I find no easy way (except using a skin) that enables two things:

    I want to have two bars - on "overall" and one for "current step".
    I use the default skin (nothing changed) and get the following results:

    A lime bar for value1 - no bar (shade or whatever) for value2.

    It would be great to have some properties "Value1 - Bar Color / Value2 - Bar Color" or such a thing.
    But I can't find anything like this.

    Is there an easy way to get such a "2 bar progress"?
    Is there also a way to display the value (percent) of value2 somewhere like with value1?

    Regards

    Manfred
  2. Boyko Markov
    Admin
    Boyko Markov avatar
    610 posts

    Posted 28 Mar 2008 Link to this post

    Hello Manfred Pohler,

    Thank you for contacting us.
    • It is odd that you need to call refresh to update visually the value. I wasn't able to reproduce it. Please open a new support ticket and send me a simple application which reproduces this behavior.
    • Indeed Value2  is represented only by shade. You cannot modify its drawing with the current implementation.
    • We will consider adding BarColor properties for Value1 and Value2 in the future releases. Thank you for your request.

    I'm looking forward to your response.

    Greetings,
    Boyko Markov
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. UI for WinForms is Visual Studio 2017 Ready
  4. kissanya
    kissanya avatar
    2 posts
    Member since:
    Sep 2010

    Posted 15 Apr 2011 Link to this post

    I have this problem as well.

    Mentioning that the percentage is refreshing but the bar is not growing after a time(!) when is used from event.
    The problem can be only solved with refreshing the whole form.

    Best regards,

    kissanya
  5. Ivan Petrov
    Admin
    Ivan Petrov avatar
    701 posts

    Posted 20 Apr 2011 Link to this post

    Hi kissanya,

    Thank you for writing.

    I would kindly ask you to provide some more details about the scenario in which you are experiencing this issue. Which is the version of the Telerik controls you are currently using? In addition, if you have the time to prepare a sample project and send it to us, you will greatly descrease the time frame in which we will be able to locate and solve the issue.

    I am looking forward to your response.

    Best wishes,
    Ivan Petrov
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top