problems with panelbar and EnableHostControlMode

8 posts, 0 answers
  1. GUIjunkie
    GUIjunkie avatar
    10 posts
    Member since:
    May 2007

    Posted 25 May 2007 Link to this post

    to a shaped form, i added a panelbar with a few groupelements. i toggled one of the groupelements to EnableHostControlMode.

    initially i was able to add a treeview to the groupelement in question; however, when i ran the app it flickered really bad and then crashed after i tried to collapse the groupelement.

    now it's to the point to where i can't even toggle the groupelement to EnableHostControlMode without crashing the VS IDE.

    ultimately, i want to add treeviews to groupelements and have no flickring.

    thanks....
  2. Boyko Markov
    Admin
    Boyko Markov avatar
    610 posts

    Posted 28 May 2007 Link to this post

    Hello John,

    Thank you for your question. Before getting to it, I would like to point you to our License Developer service that the Telerik site offers. If your company has already purchased a license from us, please ask them to add you as the license developer. You can find more information on this here: www.telerik.com/faq/.

    I've tested the RadPanelBar with the information you have provided. Basically, I added a new instance of RadPanelBar to a ShapedForm, then added three RadPanelBarGroupElements. I've set the EnableHostControlMode property of the first group to true and added an instance of TreeView into the panel of that group. When I ran the app there was no flickering, so I am not able to reproduce your problem. 

    It is possible that I am missing something. Could you give me more information on replicating the problem? I will also need information on the style of your RadPanelBar (ListBar, OutLookNavPane, VS2005ToolBox, ExplorerBar), the version of RadControls for WinForms you currently use, and if possible a sample project demonstrating the faulty behavior. You can send us the sample project in a new support ticket.

    I'm looking forward to your reply.


    Sincerely yours,
    Ray
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. UI for WinForms is Visual Studio 2017 Ready
  4. GUIjunkie
    GUIjunkie avatar
    10 posts
    Member since:
    May 2007

    Posted 29 May 2007 Link to this post

    we are in the process of purchasing six licenses; however, government agencies tend to take a bit longer than others.

    all we're trying to do at this point are put together some mock GUI screens to show management and we're seeing some flaky issue. for instance, another thing that troublesome is trying to use the RadTreeView property builder. now and then, when working in the builder, the IDE crashes.

    thanks...
  5. Boyko Markov
    Admin
    Boyko Markov avatar
    610 posts

    Posted 30 May 2007 Link to this post

    Hello John,

    Could you please give us some more information how to reproduce the faulty behavior so that we are able to provide you with appropriate help for your issues? I will appreciate it if you send me the exact version of RadControls for WinForms you are currently using and the steps to reproduce the IDE crash.

    Thank you for the valuable feedback.
     

    All the best,
    Ray
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  6. GUIjunkie
    GUIjunkie avatar
    10 posts
    Member since:
    May 2007

    Posted 30 May 2007 Link to this post

    thanks for the reply ray.

    i have a panelbar with four groupelements. each groupelement is host control mode enabled, with a treeview added. modifying one of the treeviews through the treeview property builder was crashing the IDE. i've since deleted the treeview, started over and now it seems to work fine.

    it looks like version 3.0.0.0 with a runtime version of v2.0.50727(which is our currewnt framework version i believe).  again, this is just the eval and we have 6 licenses on the way.
  7. Boyko Markov
    Admin
    Boyko Markov avatar
    610 posts

    Posted 30 May 2007 Link to this post

    Thank you for the additional information, John.

    I would suggest downloading the newest version of RadControls for Winforms (Q1 SP1, aka v3.1), as we have fixed many of the bugs found in the Q1 release of our suite.

    I will be happy to help you with any future questions you might have.


    Kind regards,
    Ray
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  8. Hein Boonzaaier
    Hein Boonzaaier avatar
    1 posts
    Member since:
    Dec 2006

    Posted 06 Jun 2007 Link to this post

    I'm having this same problem - VS does not even want to open the form now and hangs and then bombs if I open the solution with this one form with the &^$%&*$%E panelbar inside it.

    When run - it also flickers once I click on any of the panels. I am running the latest version, i.e. Q1 2007.

    I am adding controls dynamically at runtime to a contentpanel in each of the panels. I have deleted the panelbar and redid the thing twice now.

    I am going to kill it soon....
  9. Vassil Petev
    Admin
    Vassil Petev avatar
    1765 posts

    Posted 06 Jun 2007 Link to this post

    Hi Hein,

    Will it be possible to open a support ticket and send us your application? We suspect that you are using a version older than Q1 SP1. At any rate, we would be happy to review your application and provide you with a solution.

    Thank you in advance.


    Kind regards,
    Rob
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
Back to Top
UI for WinForms is Visual Studio 2017 Ready