IOS Upload To iTunes Connect - No Waiting for Upload

16 posts, 0 answers
  1. Michael
    Michael avatar
    21 posts
    Member since:
    Apr 2011

    Posted 10 Sep 2014 Link to this post

    I think Apple may have changed the process for submitting new versions.

    I have previously uploaded builds from within AppBuilder but now I am getting an error saying "There is no matching application in iTunes Connect with status Waiting For Upload...

    In iTunes Connect the screens look to have changed, I have created and saved a new version and the status is now "Prepare for Submission". there is a button that says "submit For Review" but it will not let me do this without selecting the build ( it says Submit your builds using Xcode 5.1.1 or later, or Application Loader 2.9.1 or later.)

    I can't get it to the "Waiting For Upload" state?

    How do I upload it without a MAC?

  2. Kaloyan
    Admin
    Kaloyan avatar
    872 posts

    Posted 12 Sep 2014 Link to this post

    Hello Michael,

    As said in your other thread:

    "Within the latest AppBuilder version (2.5) we introduced a new workflow that corresponds to the Apple's publishing process. After updating, you should be able to once again publish your iOS applications directly through our clients, without the need of Macs. Please, note the steps described in the reworked documentation article as they now differ from the old ones."

    I hope this helps.

    Regards,
    Kaloyan
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
  3. Support
    Support avatar
    8 posts
    Member since:
    Jun 2013

    Posted 13 Sep 2014 in reply to Kaloyan Link to this post

    Hello,

    I followed the procedure to upload the APK from Visual Studio (http://docs.telerik.com/platform/appbuilder/publishing-your-app/distribute-production/publish-ios).

    But when I add the build (inside iTunes Connect), click on 'Save' and then click on 'Submit for Review', I always get the following message (the upload from Visual Studio is successfully achieved with message "Application uploaded successfully"):

    "You must submit your builds using Xcode 5.1.1 or later, or Application Loader 2.9.1 or later. After you’ve submitted a build, select it in the Builds section below."







  4. Support
    Support avatar
    8 posts
    Member since:
    Jun 2013

    Posted 15 Sep 2014 in reply to Support Link to this post

    Any idea how to fix this?
  5. Kaloyan
    Admin
    Kaloyan avatar
    872 posts

    Posted 17 Sep 2014 Link to this post

    Hi Support,

    After a successful publish from AppBuilder you will need to perform the following steps in iTunesConnect:

    1. In the Prerelease tab, verify that your build is uploaded.
      After the upload in Application Loader completes, Apple processes the binary and shows it in a Processing state in the Prerelease tab. To be able to continue with publishing your app, the build must not be in the Processing state.
    2. In the Versions tab, scroll down to Build and click +.
    3. Select your build from the list and click Done.
    4. Click Save.
    5. Click Submit for Review.
      The status of your app is now Waiting for Review.

    Here is a short video about that, I hope it helps.

    Please, let me know if you need further assistance.

    Regards,
    Kaloyan
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
  6. Kjell
    Kjell avatar
    275 posts
    Member since:
    Jun 2010

    Posted 21 Sep 2014 in reply to Kaloyan Link to this post

    My app update is in "Prepare for Submission" status, but when I try to upload it via Appbuilder I get:

    Cannot verify binary upload.  Visit https://itunesconnect.apple.com/ to verify that your application is in the Upload Received or Waiting for Review state. 

    In itunes connect there is no build shown and it just has the message about uploading with x-code.
  7. Ferry v.d. Graaf
    Ferry v.d. Graaf avatar
    6 posts
    Member since:
    Sep 2004

    Posted 23 Sep 2014 Link to this post

    We are having the same issue:
    - Cannot verify binary upload. Visite.... to verify that your application is in the Upload Received or Waiting for Review state.

    Also when I use Application Loader 2.9.1 or later, I get the issue it is an invalid IPA or ZIP file.
  8. OfficeHeart
    OfficeHeart avatar
    99 posts
    Member since:
    Aug 2008

    Posted 23 Sep 2014 Link to this post

    same problem.

    please help!!
  9. Support
    Support avatar
    8 posts
    Member since:
    Jun 2013

    Posted 23 Sep 2014 Link to this post

    Ok. Problem solved!

    Once you choosed your build, you'll not be able to send it to review immediately... and I don't know why. Just wait one day and go back to your itunes connect and then you'll be able to do it.

    Cheers,
    Bastien
  10. Kaloyan
    Admin
    Kaloyan avatar
    872 posts

    Posted 24 Sep 2014 Link to this post

    Hi guys,

    The AppBuilder team is currently investigating what could the reason for such errors be. We will let you know as soon as we have any results on the matter.

    Thank you for the understanding and the patience in advance.

    Regards,
    Kaloyan
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
  11. Mike
    Mike avatar
    17 posts
    Member since:
    Jan 2014

    Posted 25 Sep 2014 Link to this post

    I am having the same exact problem as the original post.  I followed the instructions mentioned in the first reply and still get the same error. 
  12. Blue
    Blue avatar
    11 posts
    Member since:
    Jun 2013

    Posted 29 Sep 2014 Link to this post

    I am also still getting this problem.
    Any news on a possible solution ?
  13. Kaloyan
    Admin
    Kaloyan avatar
    872 posts

    Posted 29 Sep 2014 Link to this post

    Hi,

    We identified an issue related to our publishing feature. We even managed to apply a fix for it on https://devapp.icenium.com/Mist/Dashboard?tap=off. Could you please, follow the steps from this sticky forum thread and check if you can publish you application as expected from there?

    I hope the issue is resolved. Still, if errors occur you can send us Fiddler logs in private support tickets in order to continue our investigation.

    Please let us know of the results.

    Regards,
    Kaloyan
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
  14. Blue
    Blue avatar
    11 posts
    Member since:
    Jun 2013

    Posted 30 Sep 2014 Link to this post

    Hi,

    I still get the same error message when using the solution provided by Kaloyan.
    I will get the Fiddler logs soon and create a private support ticket.

    Regards,
    Blue
  15. OfficeHeart
    OfficeHeart avatar
    99 posts
    Member since:
    Aug 2008

    Posted 30 Sep 2014 in reply to Kaloyan Link to this post

    Hello,

    I can confirm that this works for us!
    Hopefully this fix wil be fast released in windows appbuilder.


  16. Kaloyan
    Admin
    Kaloyan avatar
    872 posts

    Posted 01 Oct 2014 Link to this post

    Hi there,

    @OfficeHeart Thank you for sharing the results with us!

    @Blue We are looking forward to receiving logs from the publishing process on the devapp environment. Please, have in mind that sometimes you can be redirected back to app.icenium.com. If this had happend, it is epxected for the publish to fail again. So, please keep an eye to the environment in which the browser is working and if you see that you are redirected back to app.icenium.com, stop and try to get back to devapp.icenium.com. There are also some known issues on the devapp environment. For example, you may be prompted with the following message right after getting in: "AppBuilder cannot load workspace!". This can be ignored, by pressing the okay button. Further, if your solution does not load from the first time (you see an empty solution pane or something similar), please check if refreshing (Ctrl + F5) the web page solves the matter. I hope this helps. Still, feel free to share any fiddler logs with us in your previously opened support ticket on the same matter.

    Regards,
    Kaloyan
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
Back to Top