Invalid Value of Parameter Error

2 posts, 0 answers
  1. Christine
    Christine avatar
    1 posts
    Member since:
    Feb 2014

    Posted 17 Apr 2014 Link to this post

    I changed one of my report parameters to allow Null, the data query returns valid data when the parameter is Null, and yet I keep getting an error in Telerik report designer when attempting to do a report preview with the parameter set to Null. I'm using Q1 2014. Is this a bug with the system? I've never had this issue before.
  2. Stef
    Admin
    Stef avatar
    3050 posts

    Posted 18 Apr 2014 Link to this post

    Hi Christine,

    The attached TRDX file is created with the Standalone Report Designer tool that accompanies your Telerik Reporting Q1 2014 installation. The report contains a single parameter that allows Null values to be selected. Also to retrieve data we use a data source component wrapping a parameterized data retrieval method (the data retrieval method parameter is mapped to the report parameter e.g. as in the steps in the SqlDataSource Wizard article).

    Please compare the settings to yours, and verify the report parameter is mapped correctly to the data retrieval method's parameter, and the Null value is interpreted correctly.

    In order to investigate the issue further, please send us test data and your report definition code to check the settings. If you prefer to not post these details in the forum, feel free to open a support ticket and attach your files there.

    Regards,
    Stef
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  3. DevCraft banner
Back to Top