Editor doesnt allow editing when grid pop edit open for the second time.

12 posts, 0 answers
  1. CC
    CC avatar
    4 posts
    Member since:
    Feb 2010

    Posted 12 May 2014 Link to this post

    I am currently using a data grid which has a pop up grid editor and Kendo Editor. I am able to modify the fields in the pop up windows the first time its loads but on any other attempts there after I am not able to edit the fields. But if the Kendo Editor is removed everything works fine.
  2. Dimiter Madjarov
    Admin
    Dimiter Madjarov avatar
    2156 posts

    Posted 14 May 2014 Link to this post

    Hello Corey,


    I tried to reproduce the issue on my side, but to no avail. Please send us a small isolated example, which demonstrates it or modify some of our Code Libraries, for example this one, so I could review it locally and provide assistance.

    I am looking forward to hearing from you.

    Regards,
    Dimiter Madjarov
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  3. UI for ASP.NET MVC is VS 2017 Ready
  4. Eric
    Eric avatar
    19 posts
    Member since:
    Mar 2014

    Posted 30 Jul 2014 Link to this post

    VS 2013 Pro
    MVC 5
    v 2014.2.716

    I have the same issue, although mine is that the Editor (Kendo EditorFor) is within an EditorTemplate for a Kendo ListView item. See attached project.

    I can only edit one record. When I choose another to edit, the editor opens, but everything is read only .

    In my example, when running, go to http://localhost:49520/Home/Community
    Thanks



  5. Eric
    Eric avatar
    19 posts
    Member since:
    Mar 2014

    Posted 30 Jul 2014 in reply to Eric Link to this post

    To upload that example, I removed packages, kendo style files, script files, binaries, database, and themes, to make it small enough. You'll have to replace those items from 2012.2.716 to make it work.
  6. Eric
    Eric avatar
    19 posts
    Member since:
    Mar 2014

    Posted 30 Jul 2014 in reply to Eric Link to this post

    Actually, the editor window is read only until you hit an editing style button, like bold, and then it places the cursor in the edit window, and you can edit the text - but it's still light grey in color, as though it's still read only.
  7. Dimiter Madjarov
    Admin
    Dimiter Madjarov avatar
    2156 posts

    Posted 31 Jul 2014 Link to this post

    Hello Robert,


    Thank you for providing the sample project. Nevertheless I was unable to reproduce the issue on my side. Could you please let me know the exact steps to take in order to observe the behavior and in which browser?

    Thanks in advance.

    Regards,
    Dimiter Madjarov
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  8. Eric
    Eric avatar
    19 posts
    Member since:
    Mar 2014

    Posted 31 Jul 2014 in reply to Dimiter Madjarov Link to this post

    This only happens in IE 11

    This does not happen in the latest versions of Chrome, Opera, FireFox, or Safari (for Windows at least - 5.1.7)

    This is REALLY verbose, so bear with me...
    Build, run, go to: http://localhost:49520/Home/Community with IE
    See Pic1
    Click Edit on any message - I chose the top one
    See Pic2
    Make changes
    See Pic 3
    Click Save (checkbox) button
    See pic 4
    Click Edit on any message and the editor shows, the mouse icon is changed to the I-beam, but you can't edit
    See pic 5
    Click any editor toolbar for text editing
    See pic 6
    Now you can edit text and save.
    See pic 7
  9. Dimiter Madjarov
    Admin
    Dimiter Madjarov avatar
    2156 posts

    Posted 01 Aug 2014 Link to this post

    Hello Robert,


    Thank you for the additional information. We managed to reproduce the issue on our side in Internet Explorer 11 and it is logged for further investigation from the developers team. We will get back to this thread, when more information is available.

    As a small sign of gratitude I updated your Telerik points.

    Regards,
    Dimiter Madjarov
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  10. Eric
    Eric avatar
    19 posts
    Member since:
    Mar 2014

    Posted 01 Aug 2014 in reply to Dimiter Madjarov Link to this post

    Thanks!
  11. Dimiter Madjarov
    Admin
    Dimiter Madjarov avatar
    2156 posts

    Posted 05 Aug 2014 Link to this post

    Hi Robert,


    The developer team addressed the issue and the fix will be available in the next internal build. It should be live by the end of the day or tomorrow.

    I wish you a great day!

    Regards,
    Dimiter Madjarov
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  12. Mike
    Mike avatar
    16 posts
    Member since:
    Feb 2014

    Posted 08 Aug 2014 in reply to Dimiter Madjarov Link to this post

    I'm having the same issue. able to edit the first time, but not able to edit the second time.

    Using version: 2104.2.716
    IE 9
  13. Dimiter Madjarov
    Admin
    Dimiter Madjarov avatar
    2156 posts

    Posted 11 Aug 2014 Link to this post

    Hi Mike,


    As mentioned previously indeed the issue is reproducing in the Q2 2014 release. The fix is available in the latest internal build, available in your profile.

    Regards,
    Dimiter Madjarov
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
Back to Top
UI for ASP.NET MVC is VS 2017 Ready