Control give problem after Upgrade to Q1 2011

7 posts, 0 answers
  1. Johnny
    Johnny avatar
    86 posts
    Member since:
    Dec 2010

    Posted 04 Apr 2011 Link to this post

    Hi!

    I will like to ask certain thing about upgrade. From starting we are using the Q2 2010 (Trial Version), than we already purchase Q1 2011. So we use the wizard to upgrade the project. On code there is no error, but by performence vice... something was happen.

    In Form designer mode. For example, my form designer and porperties is open by side. So when i click on the button the properties will show me the name of the button. But most of the time after i go to code mode and click back the form design, and select some button or ribbon bar it didn't show me the correct name. I also had try to select on other control and select back the control i want to see the name in properties it also didn't show me the correct name. WHY?

    One more things when i select the form to view in design mode it populate the control very slow and sometime after finish populate and view the form design, i open the form code mode then select back the form design mode, it was not responsing or hanging...

    Im develop my project in Visual Studio 2010 - (VB.NET).
    Im using the RibbonBar form.
    In the form i had docker, button, ribbonbar, treeview, label, Theme Manager and more...


    Regards
    Johnny
  2. Richard Slade
    Richard Slade avatar
    3000 posts
    Member since:
    May 2009

    Posted 04 Apr 2011 Link to this post

    Hello,

    I haven't seen these performance issues that you have described in the latest release. There are however many changes and enhancements in the newest release which you can learn more about by visiting the release notes.

    If you can post a small sample that demonstrates your issues, I'll be happy to take a look
    Thanks
    Richard
  3. UI for WinForms is Visual Studio 2017 Ready
  4. Stefan
    Admin
    Stefan avatar
    2891 posts

    Posted 07 Apr 2011 Link to this post

    Hi Johnny,

    Thank you for writing.

    I would suggest that you uninstall all versions of RadControls for WinForms from your machine and then install just the latest version. After that make sure that your project has references to the new assemblies and test these scenarios again.

    Let me know if this helps.
     
    Best wishes,
    Stefan
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Johnny
    Johnny avatar
    86 posts
    Member since:
    Dec 2010

    Posted 13 Apr 2011 Link to this post

    Sorry to reply late... currently are busy to meet the duedate of the project.

    I still having that issue after try as you said. Delete all RadControl and install the Q1 2011 (purchased).


    I will try to find out more what is the cause of this when i was free then i will write in here again.

    Thank!

    Regards
    Johnny
  6. Stefan
    Admin
    Stefan avatar
    2891 posts

    Posted 15 Apr 2011 Link to this post

    Hello Johnny,

    Thank you for your reply. I am looking forward to the details that you can give me regarding this issue.
     
    Best wishes,
    Stefan
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  7. Johnny
    Johnny avatar
    86 posts
    Member since:
    Dec 2010

    Posted 09 May 2011 Link to this post

    Sorry to reply late....
    It's because i got no choice and had to redo the whole project again with the Q1 2011.
    It was less issue already but i got few issue that i need the help from you guys....

    1) How can i disable the right click function on the tab of the documentwindow?
    2) How can i disable the TAB key on keyboard...(What i mean is when we press tab key in keyboard we will able to shortcut key. I don't want to had that function.
    3) At ribbon... after i add theme black office u will see some black line after u create the button at ribbon. That actually show the application. When i reopen and select ribbon sometime it didn't appear the name at the properties... why?

    Regards
    Johnny
  8. Stefan
    Admin
    Stefan avatar
    2891 posts

    Posted 12 May 2011 Link to this post

    Hello Johnny,

    Thank you for writing.

    Before getting to your questions, I would like to kindly ask you to keep the discussion in one thread to the initial subject as stated in this forum thread, paragraph 4. Also try to avoid publishing the same questions numerous times, since this slows down our response time. If you have an urgent issue, please use our Support Ticketing system, otherwise, post it in a forum thread, where the community can benefit from the answer.

    1) Your first question is already answered in the other forum thread which you have opened - http://www.telerik.com/community/forums/winforms/page-view/disable-right-click.aspx.

    2) I need some further information regarding this requirement:
    • Where (in which control) you want to disable this key? 
    • Which behavior you want to stop?
    • What behavior do you expect?
    3) I have added RadRibbonBar control on the form and I have added Office2010Black theme too. Then I assigned the theme to the control and I have added couple of buttons. Such lines did not appear. Could you please describe the exact steps to reproduce? And also providing an image of the undesired behavior might be helpful.

    I am looking forward to your reply.
     
    Best wishes,
    Stefan
    the Telerik team
    Q1’11 SP1 of RadControls for WinForms is available for download; also available is the Q2'11 Roadmap for Telerik Windows Forms controls.
Back to Top
UI for WinForms is Visual Studio 2017 Ready