Command to Message Server times out Error

14 posts, 0 answers
  1. Sushma
    Sushma avatar
    1 posts
    Member since:
    Nov 2015

    Posted 21 Nov 2015 Link to this post

     Hi

     I have installed Telerik Test Studio on my windows laptop and i am trying to record a IOS app from IPAD connecting to my laptop. In IPAD i have Telerik Mobile Testing and the connectivity to IPAD thru Mobile Testing from Telerik Test studio is established on port 8082. The connectivity from test studio to IPAD is successful and I am able to view the connected device on my windows box.

    However while I am trying to record the IOS application, I get an error msg saying “ Command to message server timed out” as seen in the attached screenshot below.
    I have set the IOS time out and Message server details 
    IOS USB Connect Timeout- 1000
    Message ServerIP: ip address of my machine
    Message Server port: 8084
    Attached Screenshots of the error.

    Wanted your help in understanding if TestStudio will work on Windows while connected to IPAD(communicating through Mobile Testing) or is there any workaround for the recording of IOS app navigation from IPAD.

    Your valuable inputs are highly appreciated.

  2. Ivaylo
    Admin
    Ivaylo avatar
    750 posts

    Posted 25 Nov 2015 Link to this post

    Hello,

    I am closing this as a duplicate.

    Thank you for your understanding.

    Regards,
    Ivaylo
    Telerik
     
    Test your Android and iOS apps against any device or browser with Telerik Mobile Testing. Part of the Telerik Platform.
     
  3. Vel
    Vel avatar
    1 posts
    Member since:
    Jan 2016

    Posted 07 Jan Link to this post

    The problem is solve or not 

     

  4. Nidzie
    Nidzie avatar
    3 posts
    Member since:
    Nov 2012

    Posted 11 Jan in reply to Vel Link to this post

    Hi Vel,

    I am facing the same problem but unable to find the solution. Can you please help?

    Thanks and Regards,

    Nidz

  5. Nidzie
    Nidzie avatar
    3 posts
    Member since:
    Nov 2012

    Posted 11 Jan in reply to Ivaylo Link to this post

    Hi Ivaylo,

    I understand the above post is duplicate. Could you help me by redirecting me to the original post. I am facing the same problem and unable to resolve the error.

    Thanks and Regards,

    Nidz

  6. Ivaylo
    Admin
    Ivaylo avatar
    750 posts

    Posted 12 Jan Link to this post

    Hello,

    Try changing the port of the message server and let me know if  you are able to connect.
    Refer to the screenshot for more details.

    Regards,
    Ivaylo
    Telerik
     
    Test your Android and iOS apps against any device or browser with Telerik Mobile Testing. Part of the Telerik Platform.
     
  7. Nidzie
    Nidzie avatar
    3 posts
    Member since:
    Nov 2012

    Posted 29 Jan in reply to Ivaylo Link to this post

    Thank you Ivaylo. The issue is resolved now.

    Regards,

    Nidhi

  8. Ivaylo
    Admin
    Ivaylo avatar
    750 posts

    Posted 29 Jan Link to this post

    Hello,

    Glad to hear this has been resolved. 

    I am closing this case.

    Regards,
    Ivaylo
    Telerik
     
    Test your Android and iOS apps against any device or browser with Telerik Mobile Testing. Part of the Telerik Platform.
     
  9. Rich
    Rich avatar
    1 posts
    Member since:
    Feb 2016

    Posted 22 Feb in reply to Ivaylo Link to this post

    I am having the same problem. I checked my settings and they are exactly as you have shown in the screenshot. What else should I try? In addition, when I try to run the demo tests, they all FAIL.
  10. Ivaylo
    Admin
    Ivaylo avatar
    750 posts

    Posted 24 Feb Link to this post

    Hello,

    Did you try changing the port? 

    If you continue experiencing a problem please submit a new ticket/thread and provide more detailed information.

    Thank you.

    Regards,
    Ivaylo
    Telerik
     
    Test your Android and iOS apps against any device or browser with Telerik Mobile Testing. Part of the Telerik Platform.
     
  11. Vivek
    Vivek avatar
    2 posts
    Member since:
    Apr 2016

    Posted 11 May Link to this post

    Hi I am facing the same problem and as per the solution in the above posts, i tried after chaning the Message Server Port, still getting the same error.

    "Command to message server times out"

    Please resolve my issue ASAP.

    :(

  12. Kalyan
    Kalyan avatar
    2 posts
    Member since:
    Jul 2016

    Posted 08 Sep Link to this post

    Tried the solution said above but error didn't resolve. Same thing. Is somebody from telerik there to answer this?
  13. Kalyan
    Kalyan avatar
    2 posts
    Member since:
    Jul 2016

    Posted 08 Sep Link to this post

    Should the message server port and Device port should be the same?
  14. Nikolay Petrov
    Admin
    Nikolay Petrov avatar
    81 posts

    Posted 13 Sep Link to this post

    Hello Kalyan,

    To your last question - it depends on the type of connection you are using - for USB connection, the device port should be different than the message server port whereas for Wi-Fi connection the device should connect to a running message server and therefore use the message server's port and host.

    Please, share the version of the product that you are using. It is recommended to upgrade to the latest internal build - 2016.2.824. 

    Let me know if this solves the issue.

    Regards,
    Nikolay Petrov
    Telerik by Progress
     
    Test your Android and iOS apps against any device or browser with Telerik Mobile Testing. Part of the Telerik Platform.
     
Back to Top