AppBuilder very slow and commit never returns

2 posts, 0 answers
  1. Darren
    Darren avatar
    32 posts
    Member since:
    Sep 2013

    Posted 17 Mar 2014 Link to this post

    Hi

    I have noticed AppBuilder getting slower and slower.
    I am trying to commit my projects changes and the commit never returns. If I change it to only a few files is may work occasionally.

    Are others having this problem too.

    Thanks
    Darren
  2. Iva Koevska
    Admin
    Iva Koevska avatar
    286 posts

    Posted 18 Mar 2014 Link to this post

    Hi Darren,

    We are aware that git operations with multiple files might be slow and cause issues. We are working on improving this behavior. Until we come up with an optimized solution, please, resort to making small incremental commits and push operations. Thank your for the patience and understanding.

    Regarding the slow down in performance you're observing, we would like to investigate this issue further. Would you mind describing in detail the behavior you're observing? We are looking for information such as:
    • What AppBuilder client are you using?
    • Do you observe the slow down only in terms of git operations?
    • Do you observe a general slow down in all performance?
    • Does this slow down affect a single session or is it a general observation, e.g. comparing one release to the other? 
    • Have you noticed a spike in resource consumption that affects your entire system? E.g., an unusual spike in memory and CPU consumption.
    • If yes, have you noticed a pattern?
    • Anything else you have noticed and believe to be related to this "slower and slower" behavior.

    Thank you for sharing this information as it can help us improve AppBuilder.

    Regards,
    Iva Koevska
    Telerik
     
    Icenium is now Telerik AppBuilder, and is part of the Telerik Platform. Share what you think about AppBuilder and Telerik Platform with us in our feedback portal, so we can become even better!
Back to Top