ALT keyboard sequences not working when RadRibbonBar is present

5 posts, 1 answers
  1. Kelly Hamilton
    Kelly Hamilton avatar
    9 posts
    Member since:
    Nov 2009

    Posted 29 Jun 2012 Link to this post

    Hi, I'm having a problem with the RibbonBar KeyTips grabbing ALT keyboard sequences and I'd like to get them working again. I have a form with a TreeView on it. While inline editing tree node text, we used to be able to enter Alt keyboard sequences (Like ALT+130) to put special characters in the text. After adding a Ribbon Bar to the form, the Ribbon Bar is taking the ALT on the keyup and showing the KeyTips instead. 99% of the time, the Keytips are useful and we'd like to keep using them, but we need these keyboard shortcuts to work as well.
    We are using v 2011.3.11.1219 for our release. I tried 2012.2.608.20 and it has the same problem.
     
    I can reproduce this by creating a new application and adding a TreeView with some nodes. Before upgrading to a Telerik Windows Forms application, the ALT keyboard sequences can be entered into the TreeeView's inline edit. Upgrade the solution to a Telerik Windows Forms solution, change the Form to inherit RadRibbonForm, Add a RadRibbonBar, add a button group (I set the KeyTip to "A"), and add a Button Element. I can send the sample application if needed.

    Is there a solution for this? Or plans to get the RibbonBar to only respond to a naked ALT key and pass the Key Sequences on to the Inline Edit box? I realise disabling the Keytips would probbaly pass on the keyboard sequence, but as I said, I'd like to get both working if possible.

    Thanks, Kelly
  2. Peter
    Admin
    Peter avatar
    1148 posts

    Posted 03 Jul 2012 Link to this post

    Hi Kelly,

    Thank you for writing.

    By default RadRibbonBar uses the ALT+key combination for Key tips. Key tips allow the user to easily discover the keyboard shortcuts for any ribbon bar item. To display the valid key tips at any time, press and release the Alt key. 

    You can disable key tips by setting the EnableKeyMap property to false:
    radRibbonBar1.EnableKeyMap = false;

    If you have any additional questions, feel free to contact me. Kind regards,
    Peter
    the Telerik team
    RadControls for WinForms Q2'12 release is now live! Check out what's new or download a free trial >>
  3. UI for WinForms is Visual Studio 2017 Ready
  4. Kelly Hamilton
    Kelly Hamilton avatar
    9 posts
    Member since:
    Nov 2009

    Posted 03 Jul 2012 Link to this post

    Hi Peter, thank you for your response.I've relayed the response to my manager, and I've been told that disabling the Keytips is not an option, and since we have an international application, we must still support the ALT-Key sequences in our text boxes. His justification is that MS Word handles ALT Key sequences properly and it has a ribbon bar that has keytips that work.

    So you have any advice for me on how to be able to pass the ALT key sequences to the TreeView's inline edit box, and keep the keytips functional in the same way that MS Word handles its Keytips? The solution might be as simple as getting the ribbon bar to pass on the keypresses if the key sequence is not in the keytip list.

    Thanks,
    Kelly.
  5. Answer
    Peter
    Admin
    Peter avatar
    1148 posts

    Posted 04 Jul 2012 Link to this post

    Hello Kelly,

    Thank you for your findings.

    We will consider your suggestions. As a workaround for your case you should disable the RibbonKeyTips only in case that the RadTreeView control is in edit mode.

    To do this, you should handle the Editing event, which fires before the text of the tree node is edited, and turn on the KeyTips on the Edited event which is fired after the text of the node has been edited.

    I hope this helps.

    All the best,
    Peter
    the Telerik team
    RadControls for WinForms Q2'12 release is now live! Check out what's new or download a free trial >>
  6. Kelly Hamilton
    Kelly Hamilton avatar
    9 posts
    Member since:
    Nov 2009

    Posted 04 Jul 2012 Link to this post

    Hi Peter,
    Thank you for your repsonse, I think this work around will work. I can also apply this to ListViews and other areas showing the same problem.

    Kelly.
Back to Top
UI for WinForms is Visual Studio 2017 Ready