Why only recent old versions for download

2 posts, 0 answers
  1. Dermott
    Dermott avatar
    1 posts
    Member since:
    Jul 2010

    Posted 15 Sep 2013 Link to this post


    What is the issue with not having many previous versions of software available to developers? (In particular much older builds).

    I have a very specific need for Telerik controls that work with mono/moonlight on Linux, and although I had read you no longer support this on your latest version I was still under the impression that older versions of Telerik controls could be downloaded for developers under subscription. So I recently paid $1.5k for the DevCraft complete subscription, only to find out that I still cannot use Telerik controls for my project.

    I appreciate that you no longer support these versions, and that compatibility could be far less than 100%. However, I am trying to put something together for Linux that even with this limitation would exceed the alternative approaches, yet I cannot do this even after paying for a Telerik subscription.


    Frustrated customer.
  2. Yuliyana
    Yuliyana avatar
    2 posts

    Posted 18 Sep 2013 Link to this post

    Hello Dermott,

    Thank you for contacting us.

    Our policy, for customers that would like to use older versions of the controls, is the following: They purchase a license for the latest version, and we add a matching license for the version they need to their accounts manually.

    Could you please specify the product you are interested in having an older version for and we will acivate it right away. 

    Looking forward to hear from you.


    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

Back to Top