WCF Service and Light Switch - editing doesn't work, claims "Specified entity is not managed by a context"

2 posts, 0 answers
  1. Martyna
    Martyna avatar
    1 posts
    Member since:
    Jun 2012

    Posted 28 Oct 2013 Link to this post

    I stumbled upon an issue after following the steps described in http://documentation.telerik.com/openaccess-orm/quick-start-scenarios/getting-started-root-quickstart-vs-light-switch-wcf-ria . I can generate the Model and the Service just fine and adding the DataSource to the Lightswitch project also proceeds without a problem.

    If I afterwards create a Desktop client with a screen based on the OpenAccess Service, I can filter and view the data properly, but any attempt at editing or deleting existing records results in an error message stating "Specified entity is not managed by a context". Adding new records works alright (and the newly added records exhibit the same symptoms).

    I'm working in Visual Studio 2013 and followed the steps from the Quick Start guide. Is there something I'm missing here? Did anybody succeed at getting a LightSwitch-editable Service from OpenAccess or is it some sort of a known issue that's not stated anywhere explicitly?
  2. Dimitar Tachev
    Dimitar Tachev avatar
    67 posts

    Posted 31 Oct 2013 Link to this post

    Hello Martyna,

    Based on the provided details I was able to reproduce this behavior but unfortunately I cannot give you any workarounds at the moment.

    I have addressed a new task in our documentation for specifying more details in the LightSwitch article that you have found and we already have a task for improving the LightSwitch integration but I cannot give you a time frame for its implementation.

    Please accept our apologies for the inconvenience caused.

    Dimitar Tachev
    OpenAccess ORM Q3 2013 simplifies your model operations even further providing you with greater flexibility. Check out the list of new features shipped with our latest release!
  3. DevCraft banner
Back to Top