using loadingpanel zindex correctly

4 posts, 1 answers
  1. SelAromDotNet
    SelAromDotNet avatar
    67 posts
    Member since:
    Jul 2012

    Posted 14 Oct 2008 Link to this post

    I'm using an ajax panel with an associated loading panel. everything works fine except that the loading panel has a very high zindex and as a result it renders over the drop down menus for the top navigation. how can I fix this? I do not wish to change the zindex of my menus, I would much rather change the zindex of the panel, as it only needs to be higher than the panel it's in, nothing else needs to be hidden.

    thank you.
  2. Answer
    Serrin
    Serrin avatar
    286 posts
    Member since:
    Sep 2008

    Posted 14 Oct 2008 Link to this post

    Hello,

    By default, the z-index for the AjaxLoadingPanel is 90,000, so quite a bit higher than anything else in the suite.  Depending on what you are using for your navigation, this is the number you're working against in order to get the loading panel in the right spot.  For example, if you're using a RadMenu for your navigation, your loading panel needs to be below z-index 7000.  You can see more about the default z-index presets on this page
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. SelAromDotNet
    SelAromDotNet avatar
    67 posts
    Member since:
    Jul 2012

    Posted 14 Oct 2008 Link to this post

    i've tried setting it to 5. I've tried setting it to 0. I've even tried setting it to -1000. no matter what I put for the zindex of the loading panel, it STILL loads on top of EVERYTHING else.

    how do I stop this?

    thanks
  5. SelAromDotNet
    SelAromDotNet avatar
    67 posts
    Member since:
    Jul 2012

    Posted 14 Oct 2008 Link to this post

    okay i'm not sure what I did but it started working. thanks i've got it now!
Back to Top