Upgrade Workspace error

6 posts, 0 answers
  1. Zinc
    Zinc avatar
    23 posts
    Member since:
    Aug 2013

    Posted 16 Jul 2014 Link to this post

    I just created a new workspace today.  Then I closed down AppBuilder and re-opened it.  I click on the project and a window pop up displays saying the workspace needs to be upgraded.  I click yes to upgrade, and then an error occurs stating that the imported project c:\MobileTools.targets was not found.  See the attached images.

    Is something weird happening currently?  Because I also couldn't build for the last two hours.  I have been getting a socket error:

    Log (Exception,High): System.Net.Http.HttpRequestException: SR.net_http_client_execution_error ---> System.Net.WebException: The underlying connection was closed: A connection that was expected to be kept alive was closed by the server. ---> System.IO.IOException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. ---> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host
  2. Kaloyan
    Admin
    Kaloyan avatar
    872 posts

    Posted 16 Jul 2014 Link to this post

    Hello Zinc,

    Thank you for reporting this.

    Unfortunately, the AppBuilder services are currently experiencing degraded performance. We are working on this, in order to fix it as soon as possible. I will let you know when there is a solution.

    You can check the Telerik Platform Status page for more details.

    Thank you for your help and understanding.

    Regards,
    Kaloyan
    Telerik
     

    Share what you think about AppBuilder and Telerik Platform with us in our feedback portal, so we can become even better!

     
  3. iliev
    Admin
    iliev avatar
    36 posts

    Posted 16 Jul 2014 Link to this post

    Hello,

    We have further investigated the issue you are reporting. In order to fix the issue and prevent this from happening again, we need more details about how that happened.

    It seems you created a new project and tried to build it, but the build timed out or failed. Then you tried to open it again and it started showing the dialog and message you describe.

    Would you, please, verify if this is exactly what happened and which is the AppBuilder client you used?
    After we have this information, we will be able to fix the issue for you as soon as possible.

    Regards,
    iliev
    Telerik
     

    Share what you think about AppBuilder and Telerik Platform with us in our feedback portal, so we can become even better!

     
  4. Zinc
    Zinc avatar
    23 posts
    Member since:
    Aug 2013

    Posted 16 Jul 2014 in reply to iliev Link to this post

    What you stated is correct.  The client I use is Telerik AppBuilder (formerly Graphite).
  5. Zinc
    Zinc avatar
    23 posts
    Member since:
    Aug 2013

    Posted 16 Jul 2014 in reply to Zinc Link to this post

    Also, i have tried other projects, and although this upgrade error doesn't always appear, none of them are able to build.  I'll try again in the morning.
  6. Kaloyan
    Admin
    Kaloyan avatar
    872 posts

    Posted 21 Jul 2014 Link to this post

    Hello Zinc,

    We haven't heard from you about the issue again, so we assume it is all good now? Please, let me know if there is still something bothering and we will assist you further.

    About the matter, indeed there were issues on our live servers at that time, which were preventing iOS builds. They are fixed now and I believe everything should be back to normal. Please, accept our sincere apologies for all the inconveniences caused.

    Regards,
    Kaloyan
    Telerik
     

    Share what you think about AppBuilder and Telerik Platform with us in our feedback portal, so we can become even better!

     
Back to Top