TreeViewItem Effect

4 posts, 0 answers
  1. Todd Millett
    Todd Millett avatar
    115 posts
    Member since:
    Jul 2009

    Posted 04 Feb 2011 Link to this post

    Is there any ways i can change the effect of the treeviewitem expanding. Default behavior make the child items flow down from top if the parent item is expanded. It hits the performance and feels slower. can it be a normal populating of the child items instead of the effect.
  2. Todd Millett
    Todd Millett avatar
    115 posts
    Member since:
    Jul 2009

    Posted 08 Feb 2011 Link to this post

    Any updates on the query? Or any workaround for the same ?
  3. DevCraft banner
  4. Petar Mladenov
    Admin
    Petar Mladenov avatar
    2891 posts

    Posted 08 Feb 2011 Link to this post

    Hello Todd Millett,

    You can disable the RadTreeView's animations with the attached property AnimationManager like so:
    <telerik:RadTreeView x:Name="tree" telerik:AnimationManager.IsAnimationEnabled="False">
              <telerik:RadTreeViewItem Header="My PC">
                  <telerik:RadTreeViewItem Header="Drive A" />
                  <telerik:RadTreeViewItem Header="Drive B" />
                  <telerik:RadTreeViewItem Header="Drive C" />
                  <telerik:RadTreeViewItem Header="Drive D" />
                  <telerik:RadTreeViewItem Header="Drive E" />
                  <telerik:RadTreeViewItem Header="Drive F" />
                  <telerik:RadTreeViewItem Header="Drive G" />
                  <telerik:RadTreeViewItem Header="Drive H" />
                  <telerik:RadTreeViewItem Header="Drive I" />
              </telerik:RadTreeViewItem>
          </telerik:RadTreeView>
    Please let me know if this satisfies you or not and feel free to ask if you need more info.

    All the best,
    Petar Mladenov
    the Telerik team
    Let us know about your Windows Phone 7 application built with RadControls and we will help you promote it. Learn more>>
  5. Todd Millett
    Todd Millett avatar
    115 posts
    Member since:
    Jul 2009

    Posted 09 Feb 2011 Link to this post

    That solved the problem. Thanks.
Back to Top