TimePicker error in Chrome

2 posts, 0 answers
  1. saroj
    saroj avatar
    39 posts
    Member since:
    Oct 2011

    Posted 04 Jun 2013 Link to this post

    Hi support,

    I am getting  "Invalid language tag error"  when i select the time in chrome browser  while using kendo TimepickerFor.  Error image is attached and below is my code.

    My model class:
           [RequiredIf("MONDAY", true, ErrorMessage = "Required")]
            public DateTime? MONDAY_FROM_TIME { get; set; }
            [RequiredIf("MONDAY", true, ErrorMessage = "Required")]
            public DateTime? MONDAY_TO_TIME { get; set; }

    Partial page:
                       @(Html.Kendo().TimePickerFor(h => h.HIRE_FLEET_AVAILIABILITY.MONDAY_FROM_TIME)
                            .Format("hh:mm tt")
                            .Interval(15)
                            .Enable(Model != null ? Model.HIRE_FLEET_AVAILIABILITY.MONDAY : false)
                            .HtmlAttributes(new { @style = "width:100px" }))
                 
                            @(Html.Kendo().TimePickerFor(h => h.HIRE_FLEET_AVAILIABILITY.MONDAY_TO_TIME)
                            .Format("HH:mm")
                            .Interval(15)
                            .Enable(Model != null ? Model.HIRE_FLEET_AVAILIABILITY.MONDAY : false)
                            .HtmlAttributes(new { @style = "width:100px" }))
           
  2. Petur Subev
    Admin
    Petur Subev avatar
    1882 posts

    Posted 06 Jun 2013 Link to this post

    Hello Saroj,

    I am not sure what might cause such error and I am not able to reproduce it on my side.

    Could you please check the attached project modify it so it reproduces it and send it back so we can investigate further the case?

    Regards,
    Petur Subev
    Telerik
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
  3. UI for ASP.NET MVC is VS 2017 Ready
Back to Top