Telerik Task APP and Exchange Sync

26 posts, 0 answers
  1. Stefan
    Stefan avatar
    1 posts
    Member since:
    Sep 2012

    Posted 12 Sep 2012 Link to this post

    Hello,

    we have a problem with the task app on wp7.

    WE host an exchange 2010 and we use the exchange account also on our wp7 phones, but we can't sync the task app of telerik with the exchange server

    i entered for server https://webmail.ourdomain.com - this adress also work for the mail and calendar snyc but with the telerik task app it doesn't work.
    ERror Message: No connection to exchange-account - the request failed. The remote server retunred an error: (403) forbidden
     
    But i have access with this account to the exchange server?

    Can you help me please?

    Thanks
    Stefan
  2. Lancelot
    Lancelot avatar
    251 posts
    Member since:
    Jul 2012

    Posted 12 Sep 2012 Link to this post

    Hi Stefan,

    Can you confirm you are entering your information properly? Here is the proper format, be sure to leave the domain empty. 
    • in the username field enter your username
    • in the password field- your password
    • in the email field- your email

     In the More details section:


    Are you only getting a 403 error, or are you seeing other error codes as well?

    Good Luck,
    Lancelot
  3. DevCraft banner
  4. Fred
    Fred avatar
    5 posts
    Member since:
    Dec 2012

    Posted 03 Dec 2012 Link to this post

    Hi,
    I am using a W8 Surface and having the same problem.
    I keep getting the error message (403) Forbidden.
    I know I am putting in the right information as my email and calendar are working.
    my server is mail.officeanywhere.net.au
    What I do need to do to make this work, I am desperate to make this app work.
    Regards Fred
  5. Valentin.Stoychev
    Admin
    Valentin.Stoychev avatar
    2198 posts

    Posted 03 Dec 2012 Link to this post

    Hello Fred,

    Please follow the following steps in order to fill the Account page fields:
  6. in the username field enter your username
  7. in the password field- your password
  8. in the email field- your email
  9.  the value of the server field enter  https://mailxyz.org/EWS/Exchange.asmx  , where https://mailzyz.org  is your server

    Please let us know how it goes after you follow these steps.

    Regards, Valentin.Stoychev
    the Telerik team
    Have a suggestion or face a problem - you can use the Ideas & Feedback portal to submit ideas, feedback and vote for them.
  • Fred
    Fred avatar
    5 posts
    Member since:
    Dec 2012

    Posted 03 Dec 2012 Link to this post

    Hi Valetin,
    I have done this and still getting the error message.
    What should I do next?
  • Valentin.Stoychev
    Admin
    Valentin.Stoychev avatar
    2198 posts

    Posted 04 Dec 2012 Link to this post

    Hi Fred,

    Can you please ask your email administrators if the Exchange Web Services on your exchange server can be accessed from outside your organization. This is needed for the Tasks app to connect correctly.

    Please note that this setting is not needed for your Mail/Calendar apps, but is needed for Tasks app.

    Kind regards, Valentin.Stoychev
    the Telerik team
    Have a suggestion or face a problem - you can use the Ideas & Feedback portal to submit ideas, feedback and vote for them.
  • Fred
    Fred avatar
    5 posts
    Member since:
    Dec 2012

    Posted 05 Dec 2012 Link to this post

    I noticed that I am in a window mobile 7 forum.
    I am using the MS Surface RT tablet and I bought the  Task App form MS store.
    Does this make any difference?
    What ever I try I keep getting the (403) Forbidden error message. :-(
  • Kiril Stanoev
    Admin
    Kiril Stanoev avatar
    1511 posts

    Posted 10 Dec 2012 Link to this post

    Hi Fred,

     The synchronization, in terms of user authorization, is the same in Tasks for WP7/WP8 and Tasks for Windows 8. Any update on your issue?

    All the best,
    Kiril Stanoev
    the Telerik team
    Have a suggestion or face a problem - you can use the Ideas & Feedback portal to submit ideas, feedback and vote for them.
  • Fred
    Fred avatar
    5 posts
    Member since:
    Dec 2012

    Posted 10 Dec 2012 Link to this post

    Hi Kiril,
    Thanks for following up.
    I still cant get access to my exchange server.  I think it may be a problem at the exchange end.
    Its not giving permission for the app to access the information.
    As long as as I know others are making it work on MS exchange servers i will persevere.
    I will keep you in the loop.
    Regards Fred K
  • Ann
    Ann avatar
    3 posts
    Member since:
    Jan 2013

    Posted 24 Jan 2013 Link to this post

    Hi,

    I'm having the same kind of problem.  I signed up for an Office365 account JUST so that I could use your Tasks app on both my WP7 and my new surface.

    Following your instructions in the setting section, I've tried both entering

    https://bl2prd0811.outlook.com/owa/?exsvurl=1&realm=office365.com&wa=wsignin1.0 as my server as well as

    https://bl2prd0811.outlook.com/

    Neither works.  I get error (403) Forbidden when I try.

    HELP!!

    Ann W.
  • Kiril Stanoev
    Admin
    Kiril Stanoev avatar
    1511 posts

    Posted 28 Jan 2013 Link to this post

    Hello Ann,

    Office365 accounts are supported but sometimes they need "activation". Try adding the office365 account to your phone's accounts : settings > email+accounts. Once you've added it, try adding the account to Tasks and let me know if it works. I'd be glad to assist you further. 

    Regards,
    Kiril Stanoev
    the Telerik team
    Have a suggestion or face a problem - you can use the Ideas & Feedback portal to submit ideas, feedback and vote for them.
  • Ann
    Ann avatar
    3 posts
    Member since:
    Jan 2013

    Posted 28 Jan 2013 Link to this post

    Hi, Kiril --

    I tried this both on my Windows 7 phone and on my Surface, and am still getting the same (403) Forbidden error code.  Any other ideas?

    Ann
  • Kiril Stanoev
    Admin
    Kiril Stanoev avatar
    1511 posts

    Posted 30 Jan 2013 Link to this post

    Hi Ann,

    Could you please share with me what you enter in the synchronization fields (omitting the password, of course)

    Regards,
    Kiril Stanoev
    the Telerik team
    Have a suggestion or face a problem - you can use the Ideas & Feedback portal to submit ideas, feedback and vote for them.
  • Fred
    Fred avatar
    5 posts
    Member since:
    Dec 2012

    Posted 31 Jan 2013 Link to this post

    No matter what we do this application cannot synch with my exchange server.
    It must be at your end as I am putting all of the same information as all of my computers and phones and they all synch seamlessly.
    I have had my IT person check into it and he cant make sense of why Task APP will not get into the ES.
    We can log in the ES via the web browser with no problems so why not your app?
    When I take into account the time I have wasted  trying to make it work it is the most expensive app in the world.
    Regards Fred K
  • Valentin.Stoychev
    Admin
    Valentin.Stoychev avatar
    2198 posts

    Posted 05 Feb 2013 Link to this post

    Hi Fred,

    We are using the Exchange Web Services in order to authorize TAsks app to use your exchange server. You need to be sure that these are enabled on your server.

    Here is more info about EWS - http://msdn.microsoft.com/en-us/library/exchange/dd877045(v=exchg.140).aspx

    This is a different authentication method than the one used when you login with your web browser, so please check this with your mail administrator.

    Please let us know how it goes.

    Regards, Valentin.Stoychev
    the Telerik team
    Have a suggestion or face a problem - you can use the Ideas & Feedback portal to submit ideas, feedback and vote for them.
  • Bryan
    Bryan avatar
    2 posts
    Member since:
    Feb 2013

    Posted 08 Feb 2013 Link to this post

    I think there is definitely as issue in your app. I am on Exchange Server 2007 and cannot log in also. I get Exchange authorization failed, but I have reentered my username and password multiple times, as well as verifying I am entering the correct server settings.

    To see if my Exchange server was blocking Tasks I downloaded and tested two other apps (Tasks at Last and Viperal Tasks) with the same account settings and both can connect and sync with my Outlook account.

    I would love to try this app but I need to sync with Outlook. Any other suggestions?
  • Valentin.Stoychev
    Admin
    Valentin.Stoychev avatar
    2198 posts

    Posted 13 Feb 2013 Link to this post

    Hello Bryan,

    Do you have the Service Pack 1 installed of ES 2007?

    Regards,
    Valentin.Stoychev
    the Telerik team
    Have a suggestion or face a problem - you can use the Ideas & Feedback portal to submit ideas, feedback and vote for them.
  • Bryan
    Bryan avatar
    2 posts
    Member since:
    Feb 2013

    Posted 13 Feb 2013 Link to this post

    I was mistaken, according to the data I find online I have ES 2010. When I look at the connection status the version shows 14.2.32... and I can't see the rest or expand that column. SO it looks like the ES 2010 SP1+?
  • Faisal
    Faisal avatar
    2 posts
    Member since:
    Jan 2013

    Posted 13 Feb 2013 Link to this post

    I have a similar problem which I have described here:
    http://www.telerik.com/community/forums/metro/general-discussions/tasks-app-for-windows-8---exchange-sync-issue.aspx
  • Kiril Stanoev
    Admin
    Kiril Stanoev avatar
    1511 posts

    Posted 15 Feb 2013 Link to this post

    Hello Faisal,

    I've posted an answer in your other thread. Have a look at it and let me know what you think. 

    Kind regards,
    Kiril Stanoev
    the Telerik team
    Have a suggestion or face a problem - you can use the Ideas & Feedback portal to submit ideas, feedback and vote for them.
  • K
    K avatar
    3 posts
    Member since:
    Sep 2013

    Posted 05 Sep 2013 Link to this post

    Hi,

    I am running windows 8 and trying to use your Task App which is just not working and I cannot find a resolution on your forum.
    Basically, I am trying to connect it to my Exchange server.  I have other Apps on the laptop that I have tried in the past which connect fine with the same details.

    ANY HELP PLEASE.
  • Ivo
    Admin
    Ivo avatar
    90 posts

    Posted 06 Sep 2013 Link to this post

    Hi,
    Please follow the instructions below for setting Exchange synchronization account up:

    ·                     in the username field enter your username

    ·                     in the password field- your password

    ·                     in the email field- your email

    ·                     the value of the server field enter https://mailxyz.org/EWS/Exchange.asmx, where https://mailxyz.org is your server

    ·                     do not fill the domain field, its value is extracted automatically from the e-mail if nothing is entered into that field and check the "Server requires SSL" checkbox.

     

    Could you, please try with the described above steps and comment if you manage to sign in and sync?



    Regards,
    Ivailo Dinkov
    Telerik
    TRY TELERIK'S NEWEST PRODUCT - EQATEC APPLICATION ANALYTICS for WINDOWS PHONE 7.
    Learn what features your users use (or don't use) in your application. Know your audience. Target it better. Develop wisely.
    Sign up for Free application insights >>
  • K
    K avatar
    3 posts
    Member since:
    Sep 2013

    Posted 06 Sep 2013 Link to this post

    Hi - did all that with no luck.
    Running 2007 Exchange.

    Please help.  This would really make things easier for me.

  • Ivo
    Admin
    Ivo avatar
    90 posts

    Posted 06 Sep 2013 Link to this post

    Hello,

    Could you send us what error did you get when the sync failed?

    Regards,
    Ivo
    Telerik
    TRY TELERIK'S NEWEST PRODUCT - EQATEC APPLICATION ANALYTICS for WINDOWS PHONE 7.
    Learn what features your users use (or don't use) in your application. Know your audience. Target it better. Develop wisely.
    Sign up for Free application insights >>
  • K
    K avatar
    3 posts
    Member since:
    Sep 2013

    Posted 06 Sep 2013 Link to this post

    I get the 403 Forbidden error.
  • Ivo
    Admin
    Ivo avatar
    90 posts

    Posted 09 Sep 2013 Link to this post

    Hello,

    That  is really strange.
    Could you, please send me the exact value, you are entering into the server field?

    Regards,
    Ivo
    Telerik
    TRY TELERIK'S NEWEST PRODUCT - EQATEC APPLICATION ANALYTICS for WINDOWS PHONE 7.
    Learn what features your users use (or don't use) in your application. Know your audience. Target it better. Develop wisely.
    Sign up for Free application insights >>
  • Back to Top
    DevCraft banner