3 posts, 0 answers
  1. Hamed
    Hamed avatar
    3 posts
    Member since:
    Jan 2011

    Posted 26 Nov 2011 Link to this post

    I recently use open access version 2011.3.1116.3 as ORM. But when i build the project, this error message appeared. 

    Could not load file or assembly 'Telerik.OpenAccess.DataServices' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.

    What should i do to solve this problem?
  2. Serge
    Serge avatar
    375 posts

    Posted 30 Nov 2011 Link to this post

    Hello Hamed,

     Can you double check that you are referencing this assembly. It is containing the new data services implementation that we have provided in the last release. However this assembly has always been built targeting the .NET 4.0 framework. 

    Which framework is the project referencing this one build against? Are you actually using anything that is in this assembly, and if not can you remove the reference to it.

    I am looking forward to resolving this issue.

    the Telerik team

    Q3’11 of Telerik OpenAccess ORM is available for download. Register for the What's New in Data Tools webinar to see what's new and get a chance to WIN A FREE LICENSE!

  3. DevCraft banner
  4. Hamed
    Hamed avatar
    3 posts
    Member since:
    Jan 2011

    Posted 01 Dec 2011 Link to this post

    Hello Serge
    First of all, thanks for your support. 
    I solved the problem. I used the latest version of OpenAccess in my project and remove any links to other versions.
Back to Top