RenderMode in web config is ignored on intranet sites

4 posts, 1 answers
  1. Anthony
    Anthony avatar
    2 posts
    Member since:
    Mar 2015

    Posted 06 Sep Link to this post

    I have set all controls rendering mode to lightweight via the web config:

    <add key="Telerik.Web.UI.RenderMode" value="lightweight" />

     

    Running the site locally in chrome and in IE11 renders the output lightweight as as expected.

    Once deployed to a server and set in IE as an intranet site, the controls are then rendered classic.

    Chrome renders as lightweight, but IE seems then seems ignore this global setting in the web config. The page has the relevant meta tag to switch the document mode to IE=Edge but the rendered HTML is still in classic. Meaning all of our CSS is now useless.

    Could someone please point out what I am missing here.

    Thanks

     

    Additional Info:

    • The controls don't have individual render mode properties on them.
    • The setting is still there in the web config after deployment.

     

     

     

  2. Rumen
    Admin
    Rumen avatar
    12851 posts

    Posted 06 Sep Link to this post

    Hello,

    Does IE11 render the controls in Compat mode - you can see that in the IE Dev toolbar? Compatibility mode is not supported as noted on the Browser Support page, because it forces the browser to render the content in IE7 mode.

    Best regards,
    Rumen
    Telerik by Progress
    Do you need help with upgrading your ASP.NET AJAX, WPF or WinForms projects? Check the Telerik API Analyzer and share your thoughts.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Anthony
    Anthony avatar
    2 posts
    Member since:
    Mar 2015

    Posted 07 Sep in reply to Rumen Link to this post

    Hi,

     

    Thanks for your response.

    I have the relevent http head int he web config and the meta tag on the page in the html <head> tag too. Bur the controls are still being rendered classic. Are you saying the only way to stop his is to add the site to the list of none intranet sites?

     

    <httpProtocol>
          <customHeaders>
            <clear/>
            <add name="X-Frame-Options" value="SAMEORIGIN" />
            <add name="Strict-Transport-Security" value="max-age=7776000" />
            <add name="X-XSS-Protection" value="1;mode=block" />
            <add name="X-Content-Type-Options" value="nosniff" />
    <add name="X-UA-Compatible" value="IE=edge" />
            <!--<add name="Cache-control" value="no-store" />
            <add name="Pragma" value="no-cache" />-->
            <!--<add name="Content-Security-Policy" value="default-src='self' www.telerik.com etc" />-->
            <!--<add name="Public-Key-Pins" value="pin-sha256=base64==;max-age=7776000" />-->
          </customHeaders>

     

        <meta http-equiv="X-UA-Compatible" content="IE=edge">

     

     

  5. Answer
    Rumen
    Admin
    Rumen avatar
    12851 posts

    Posted 07 Sep Link to this post

    Hi,

    I found the following StackOverflow thread with multiple suggestions, which you can try: Internet Explorer 11 disable “display intranet sites in compatibility view” via meta tag not working.

    If none one of them fixes the issue, I'm afraid that you'll need to remove the site from the list with intranet sites.

    Best regards,
    Rumen
    Telerik by Progress
    Do you need help with upgrading your ASP.NET AJAX, WPF or WinForms projects? Check the Telerik API Analyzer and share your thoughts.
Back to Top