RadHtmlChart TooltipsAppearance ClientTemplate does not display data on binding to a value from database.

1 posts, 0 answers
  1. Jitendra
    Jitendra avatar
    1 posts
    Member since:
    Nov 2013

    Posted 12 Nov 2013 Link to this post

    Hi,
    Facing an issue while binding tooltip to database item, below is the code for reference - 

    <Series>
                        <telerik:ColumnSeries Name="Power" Stacked="true" DataFieldY="TotalPower" AxisName="Power">
                            <Appearance>
                                <FillStyle BackgroundColor="#36b8f4"></FillStyle>
                            </Appearance>
                            <LabelsAppearance Position="Center" Visible="false">
                            </LabelsAppearance>
    <TooltipsAppearance ClientTemplate="#= dataItem.TotalPower#">
                            </TooltipsAppearance>

                    
    <%--
        <TooltipsAppearance ClientTemplate="#= kendo(\'{0:dd MMM yy}\', dataItem.Date)#<br/>Power: #= kendo.format(\'{0:N2}\',dataItem.TotalPower)# kW">
                            </TooltipsAppearance>
    --%>
                                   <%--
    <TooltipsAppearance ClientTemplate="#=dataItem.Date#<br/>Power: #=dataItem.TotalPower# kW">
                            </TooltipsAppearance>--%>
                            
                        </telerik:ColumnSeries>
    </Series>

    When i use ClientTemplate in TooltipsAppearance to bind tooltip to TotalPower value (this value comes from dataset), it shows "undefined" on mouse over, and instead of ClientTemplate if dataformatstring is used then it display the value
    (<TooltipsAppearance DataFormatString="{0}"></TooltipsAppearance>).

    My requirement is that, i want to display both Date and TotalPower values in tooltip. Also, tried using kendo after googling this issue, but still without any success.

    Please help as I'm stuck into this.
Back to Top