Problem with Guid fileds

3 posts, 0 answers
  1. inanc
    inanc avatar
    17 posts
    Member since:
    Mar 2009

    Posted 14 Feb 2012 Link to this post

    Hello,

    I have a problem with guid fields. Sometimes when I recompile my wcf project based on openaccess, I see some guid  fields as string while using the dto objects in my client project. Do you have any idea about this issue?

    Thank you 
    Inanc

  2. inanc
    inanc avatar
    17 posts
    Member since:
    Mar 2009

    Posted 15 Feb 2012 Link to this post

    I found a solution for my issue. Regenarating the service client code fixes the issue. Regenarating changes the 'reference.cs' file. After first generation there is no line like 

    - using System;

    for the Guid columns forexample. After regenarating   the service client code by  using 'Configure service reference' . Actually no need to change even one parameter. After that, you can see guid columns like 

    public System.Guid Ekleyen {
                get {
                    return this.EkleyenField;
                }
                set {
                    if ((this.EkleyenField.Equals(value) != true)) {
                        this.EkleyenField = value;
                        this.RaisePropertyChanged("Ekleyen");
                    }
                }
            }

    before regeneration it was :

    public string Ekleyen {
     
    ..........

    Actually I think there is no problem witt OA orm I think. That seems like a VS 2010 issue..

    Regards
    Inanc



  3. DevCraft banner
  4. Serge
    Admin
    Serge avatar
    375 posts

    Posted 17 Feb 2012 Link to this post

    Hi Inanc,

     I am glad you found a solution to your problem. And yes, regenerating the service always helps when having problems with the code on the client side that is consuming the service. 

    Do let us know if you face further trouble. 

    All the best,
    Serge
    the Telerik team
    Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
Back to Top