Problem starting recorder for the right application

4 posts, 0 answers
  1. Jim
    Jim avatar
    2 posts
    Member since:
    Apr 2015

    Posted 13 Nov 2015 Link to this post

    I´m testing a program that needs a parameterized launch.
    I´ve found this guide: http://docs.telerik.com/teststudio/advanced-topics/coded-samples/wpf/parameterize-wpf-app

    But somehow the recorder always tries to attach itself to the application mock.
    If I close the mock as the instructions I get this error: Error inside the callback listener. Error: System.ArgumentException: Process with an Id of 12160 is not running.  

  2. Cody
    Admin
    Cody avatar
    3360 posts

    Posted 13 Nov 2015 Link to this post

    Hello Jim,

    The guide you are referring to only applies to test playback, not test recording. You'll need to configure the test to launch your real WPF application. Don't set it to launch the mock application.

    Regards,
    Cody
    Telerik
     
    Quickly become an expert in Test Studio, check out our new training sessions!
    Test Studio Trainings
     
  3. Jim
    Jim avatar
    2 posts
    Member since:
    Apr 2015

    Posted 18 Nov 2015 Link to this post

    Ok, so parameterized launch of an application is not possible if I want to use the recording option with Test Studio?
  4. Cody
    Admin
    Cody avatar
    3360 posts

    Posted 18 Nov 2015 Link to this post

    Hi Jim,

    Basically that is correct. The best we can do is to connect the recorder to an already running application as shown in the attached screen shot.

    Regards,
    Cody
    Telerik
     
    Quickly become an expert in Test Studio, check out our new training sessions!
    Test Studio Trainings
     
Back to Top
  Cast Your Vote at DevPro Connections! Cast Your Vote at  Win IT Pro Connections!