Problem running a hello world app in emulator

2 posts, 0 answers
  1. srikanth
    srikanth avatar
    1 posts
    Member since:
    Jul 2015

    Posted 09 Jul Link to this post

    Hello ,

     

    I have installed tns and also tested with tns doctor . everything is correct.

    I have created a new project using tns , added android support for it.

    Then I run it in emulator it is giving me an error :

    The new package failed because the current SDK version is older than that required by the package.

    I am using windows 8.1 x64 bit pc , Geny motion 2.5.4 with emulator as API 16(4.1.1) .

    I also have a question that what is the minimum version of android api supported by native script ?

  2. nikolay.tsonev
    Admin
    nikolay.tsonev avatar
    67 posts

    Posted 11 Jul Link to this post

    Hello,
    Thank you for your interest in NativeScript,

    For Android the minimum supported version is API level 17 as it is mentioned in our documentation.
    In regard to that you could try to deploy your app on emulator or device  with API 17 or greater and it should work normally. You could also review our getting started guide , where have been described, how to create application with NativeScript.

    I hope this is applicable for you.

    Regards,
    nikolay.tsonev
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top