Problem in Chrome with radeditor when put disabled input

7 posts, 0 answers
  1. Diyan
    Diyan avatar
    10 posts
    Member since:
    Oct 2012

    Posted 12 May 2014 Link to this post

    Hi All,
    I have problem with radeditor under Chrome (v 34.0.1847.131). I try to put a disabled input but it leads to disable everything. I even try here http://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx and in html view put Password:<input disabled="disabled" type="text" value="Template" />. After some clicks I cannot change "Password" text. With Mozilla there is no problem. 
    Can you suggest any workaround or provide some solution that prevent editing part of the text.

    Best Regards,
    Diyan
  2. Ianko
    Admin
    Ianko avatar
    1535 posts

    Posted 12 May 2014 Link to this post

    Hello Diyan,

    I am afraid that I cannot quite understand what exactly is the encountered problem.

    When a disabled input is inserted, it acts as disabled as expected under both Firefox and Chrome browsers. Please review this screencast and let me know if I am missing something.

    Regards,
    Ianko
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Diyan
    Diyan avatar
    10 posts
    Member since:
    Oct 2012

    Posted 12 May 2014 in reply to Ianko Link to this post

    Thanks for the response.
    Here is a step by step how to reproduce the problem

    1. In html editor put Password:<input type="text" disabled="disabled" value="dsds" />
    2.Go back to design mode and try to edit "Password". It should be possible?
    3. Click on the input couple of times.
    4. Try to perform step 2.

    Best Regards,
    Diyan
  5. Ianko
    Admin
    Ianko avatar
    1535 posts

    Posted 12 May 2014 Link to this post

    Hi Diyan,

    I tried to reproduce the problem with the provided steps, but to no avail. Please examine this screencast and let me know if I am missing some further steps.

    Regards,
    Ianko
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  6. Diyan
    Diyan avatar
    10 posts
    Member since:
    Oct 2012

    Posted 12 May 2014 in reply to Ianko Link to this post

    Hi Ianko,
    After you changed "Password" to "Label Edited" and clicked over the disabled input DO NOT switch to html mode. Just try to edit "Label Edited" once again. In you video it is round 31sec.

    Best Regards,
    Diyan
  7. Diyan
    Diyan avatar
    10 posts
    Member since:
    Oct 2012

    Posted 13 May 2014 Link to this post

    Finally I found a workaround. Just need to skip type="text" and it's working normally.
    Thanks once again for the effort.

    Best Regards,
    Diyan
  8. Ianko
    Admin
    Ianko avatar
    1535 posts

    Posted 13 May 2014 Link to this post

    Hello Diyan,

    another possible workaround is implementing a custom Content Filter that replaces the disabled="disabled" attribute with a marker in Design mode and bring it back in HTML.

    Regards,
    Ianko
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017