OpenAccess with Lightswitch 2012

5 posts, 0 answers
  1. Algimantas
    Algimantas avatar
    3 posts
    Member since:
    Aug 2012

    Posted 06 Sep 2012 Link to this post

    I am trying to test using OA with Lightswitch 2012.  Am running into problems.

    Create the WCF RIA services under VS2012.   Creating a Lightswitch 2012 project I can attach the DataSource to it, but when I build a screen based on the data source I get the dreaded Red X "Unable to load data" .  Any advice?  Anyone else had this problem.

    Using the same WCF RIA services build under VS2012, I can create a Lightswitch 2011 project, attach data source, building a screen everything works.  Must be something simple but I can not find it.  Any help and advice would be appreciated.

    Many thanks
    Mantas.
  2. PetarP
    Admin
    PetarP avatar
    754 posts

    Posted 10 Sep 2012 Link to this post

    Hello Algimantas,

     Currently we do have some known problems with the latest version of Lightswitch. The problem is that in the latest version they changed the way the client side code generation needs to be generated and currently our implementation does not comply with the latest requirements. This is something that we will address in our of our next service packs or releases.

    Greetings,
    Petar
    the Telerik team
    Follow @OpenAccessORM Twitter channel to be the first one to get the latest updates on new releases, tips and tricks and sneak peeks at our product labs!
  3. DevCraft banner
  4. Algimantas
    Algimantas avatar
    3 posts
    Member since:
    Aug 2012

    Posted 12 Sep 2012 Link to this post

    Thank you for your reply.

    Would you be able to give an approximate time scale for this please?

    Many thanks
    Algimantas.
  5. PetarP
    Admin
    PetarP avatar
    754 posts

    Posted 17 Sep 2012 Link to this post

    Hello Algimantas,

     Unfortunately I am not able to give you an exact time frame as when this will be done as we already have a lot of feature in mind for the upcoming release but I believe that we will be able to push that in for the first service pack after the Q3 release.
    Will that work for you?

    Greetings,
    Petar
    the Telerik team
    Follow @OpenAccessORM Twitter channel to be the first one to get the latest updates on new releases, tips and tricks and sneak peeks at our product labs!
  6. Algimantas
    Algimantas avatar
    3 posts
    Member since:
    Aug 2012

    Posted 07 Oct 2012 Link to this post

    Hi Thank you,  Look forward to the service pack.
Back to Top
DevCraft banner